7

I recently installed Ubuntu 18.04 on my ASUS X512D, and I have a problem resuming from sleep mode: the screen is black (with a working pointer) or corrupted and the only thing I can do is manually reboot the computer (and loose my work). Pretty annoying for a laptop..

Computer: AMD Ryzen R5 / AMD Radeon Vega 8 / Dual boot with WIN10 Link for specs: ASUS Zenbook S512DA-EJ162T

A picture of my corrupted screen: Corrupted screen after sleep mode

What I tried:

  • Switching to lightdm, even worse (not even the pointer on screen) so I got back to gdm3
  • Updating kernel (I tried several ones, now I run the lastest mainline one, 5.2.5)
  • A lot of things from forums and other AskUbuntu posts

I also went to Software update > additional drivers and it doesn't show any proprietary driver

Another element, I had to reinstall Ubuntu because on the first try the GPU was not recognized and Ubuntu said in the settings Unknown screen. I guess buying a computer with an AMD proc was not such a good idea to use it with Ubuntu..

Thank you to anyone who'd try helping me!

5
  • I feel your pain... I have given up for now with suspend or hibernate. I am even considering writing a script using xdotool and wmctrl to save the state of windows and workspaces to emulate it. nonetheless I can "sometimes" get it to work using 'systemctl suspend -i' AFTER unplugging the USB's and waiting for a few seconds. – pierrely Aug 5 '19 at 6:17
  • @pierrely If you someday manage to make your script work, get me in touch – clementlize Aug 11 '19 at 10:20
  • -will do, I would also like to get the scroll bar location for any opened saved and reopened windows for this "save session" script. as xdotool doesnt seem to do that, perhaps page up until no more and page down for that count to simulate it. – pierrely Aug 14 '19 at 1:02
  • meanwhile I might try and get this one to work. extensions.gnome.org/extension/1323/window-session-manager – pierrely Aug 14 '19 at 2:32
  • I had resume from sleep issues back on 18.04 on an intel laptop using nvidia drivers ... that issue went away after upgrading to 19.04 – Scott Stensland Sep 10 '19 at 21:13
8

I finally managed to fix it, and here are the steps for people having the same issue.

1. Switch from gdm3 to lightdm

To do this, open a terminal and type sudo apt-get install lightdm, or sudo dpkg-reconfigure lightdm and when asked, select lightdm as your default display manager

2. Try the fix

  1. Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left Shift key right after starting the system).

  2. Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.

  3. Go down to the line starting with linux and add at the end: amd_iommu=off. Generally, the end of the line will look like this: quiet splash amd_iommu=off

  4. Now press Ctrl + x to boot.

  5. Open your session and try suspending by closing the lid

3. Make the fix permanent

  1. From a terminal (or after pressing Alt + F2) run:

    gksudo gedit /etc/default/grub

    (or use sudo nano if gksudo or gedit are not available) and enter your password.

  2. Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append amd_iommu=off to its end. For example:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amd_iommu=off"

    Save the file and close the editor.

  3. Finally, start a terminal and run:

    sudo update-grub

    to update GRUB's configuration file (you probably need to enter your password).

I also noticed that you cannot suspend with a long press on the power button in the top-right Ubuntu menu, as it results to a crash on wake up.

--

Sources:

https://bbs.archlinux.org/viewtopic.php?pid=1858315#p1858315

https://askubuntu.com/a/19487/981926

https://askubuntu.com/a/152381/981926

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.