0

I am having difficulty in mounting a Seagate freeagent USB external drive in Ubuntu 19.04. The drive is attached to a HG635 router at 192.168.1.1.
I'm able to view the shared directory using 'files' and can see the smb: location, smb://super%20router/share/

I've created a local directory for the mount, /mnt/HG635.

The output from sudo smbclient -L //192.168.1.1 is

    Sharename       Type      Comment
    ---------       ----      -------
    IPC$            IPC       IPC Service ()
    share           Disk      linux
Reconnecting with SMB1 for workgroup listing.

    Server               Comment
    ---------            -------
    SUPER ROUTER         

    Workgroup            Master
    ---------            -------
    WORKGROUP            SUPER ROUTER

The output from sudo smbtree is

WORKGROUP
    \\SUPER ROUTER          
        \\SUPER ROUTER\share            linux
        \\SUPER ROUTER\IPC$             IPC Service ()

I've added the following line to fstab

//192.168.1.1/share /mnt/HG635 cifs guest,uid=1000,iocharset=utf8 0 0

When I run sudo mount -a the response is

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I get the same response when trying to mount the drive from the command line using sudo mount -t cifs //192.168.1.1/share /mnt/HG635/

I have the latest version of cifs & cifs-utils installed.

I also tried gio mount smb://super%20router/share and the response was

gio: smb://super%20router/share/: Location is already mounted
0

I don't have your router but I suspect it is running an old dialect of smb.

Add vers=1.0 to your list of options:

//192.168.1.1/share /mnt/HG635 cifs guest,uid=1000,iocharset=utf8,vers=1.0 0 0

In addition it may also require an earlier security mode which would be another option: sec=ntlm

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.