2

I have a a machine with specs per below where one of my VM's is windows 10 in which I'm trying to run sketchup 2019, which requires hardware acceleration to be turned on, so I'm trying to figure out how to make that happen. I won't be using it for any huge modelling or all the time so if a simple solution exists that gives non-ideal performance, I can live with it. I have a number of other VM's running and everything working great, so I'm hoping not to have to make any major changes to my qemu setup.

MB - SM X10SLM+-F, CPU - Xeon E3 1231 V3, Ubuntu 18.04, qemu 2.11

I've tried looking in windows to do this, but the places folks say to enable HW acceleration don't exist when I get there, and I'm guessing this is because this is not an ability passed through qemu to the VM. I've tried applying each of the different video options available in virtmanager (cirrus, QXL, VGA, Virtio, VMVGA, XEN) and when I boot with any of them as the selected video model I still get the same hardware acceleration not supported error. When I try to select 3D acceleration with the virtio option I get the error that virtio 3D acceleration is not supported, which I'm guessing is due to the qemu version and not having Virgl.

A few places talk about Virgl, but it seems like the Ubuntu version of qemu doesn't support this, and the guides I've found to enable this require completely building a newer qemu which I'd rather not mess with too much stuff on my VM server and risk something else breaking since everything else is working great. I did find this post, which looks almost too simple of course, but I'm also not sure about using the stein repo and if what affects it might have on everything other than just enabling Virgl. So if anyone knows of a way to add a virtual gpu that would simply make sketchup see that hardware acceleration is enabled I'd really appreciate it!

I also guess I could go buy a cheap low profile GPU and figure out a way to pass it through to the windows VM, but it just seems like a waste and shouldn't be needed.

  • 1
    Hi Tilden, as I outlined at my blog there are a few different types of 3d passthrough. If virtgl really is enough then the post you linked is true - I added all needed to the virtualization stack of Ubuntu 19.04 and Ubuntu Cloud Archive makes that available for the last LTS. So you'd either have to upgrade to 19.04 or use UCA-Stein as suggested (for virtgl) – Christian Ehrhardt Aug 5 '19 at 6:28
  • 1
    Hi Christian, thanks for the info - I did use the Stein repository and am now able to select adding 3D support. However this still didn't fix the problem - as there still isn't 3D hardware support enabled in Windows it seems. I found a post on this and OpenGL on Windows, but it doesn't look like these are working drivers for Windows. If you or anyone knows of a way to support virgl on Windows or any way to make windows think hardware support is enabled, I would appreciate it. – Tilden Jan 17 at 5:51
  • Did you ever solve this? – catbadger Mar 19 at 13:31
  • No, I never found a solution for this. Would still love help if anyone is knows how to accomplish this. – Tilden Mar 20 at 14:37
1

Currently there are not drivers for Windows that support Virgl and 3D acceleration and OpenGL. I resolved this by purchasing an inexpensive PCIE GPU to directly pass through to the VM to be able to have 3D acceleration and OpenGL on my VM. Details on how I did this are listed in this post.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.