0

Have been trying to using swift-proxy & swift-storage charms but with no luck in balancing. I am fairly new in this area so i am assuming i might be missing something: Regardless my configuration which i will be sharing the status is always like this:

swift-proxy/6* blocked executing 3 10.x.x.220 8080/tcp Not enough storage zones for minimum replicas

swift-storage-zone1/5* waiting idle 3 10.x.x.220 Incomplete relations: proxy

swift-storage-zone1/6 waiting idle 27 10.x.x.231 Incomplete relations: proxy swift-storage-zone2/4* waiting executing 16 10.x.x.245 Incomplete relations: proxy

swift-storage-zone3/6* waiting idle 6 10.x.x.225 Incomplete relations: proxy

config file: swift-proxy: zone-assignment: manual replicas: 1 swift-storage-zone1: zone: 1 block-device: vda1 overwrite: "true" swift-storage-zone2: zone: 2 block-device: vda1 overwrite: "true" swift-storage-zone3: zone: 3 block-device: vda1 overwrite: "true"

tried zone-assignment: auto and have one swift-storage application to get deployed and extended to 4 units. same result

from logs incomplete relations seems to be missing the zone

Any luck with this from anyone

  • Which charms are you attempting to deploy? Unfortunately, there are a few versions of the OpenStack charms so it would be useful to point to them directly. Which commands did you run to deploy? It looks as though you may need to run juju relate swift-proxy swift-storage – Tim McNamara Aug 8 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.