I am using Ubuntu 18.04.2. I use a TV thru HDMI and the adjustment for TV. It looks great.

When I start in they AM there is usually the favorites bar on the left that displays my favorite programs. After a few times when the computer has gone into sleep mode (or whatever that is called) and I log back in, the bar on the left is gone and I have to hit "Activities" at the top for it to show up.

I would like it to always be there. I went into "display" settings and the "Auto-hide the Dock" is off. That seems to be the only thing that sounds like it should apply.

Does anyone know what to do?

  • If you're using Ubuntu, you should tell us your release. The mention of activities makes me think of gnome, but are you using Vanilla-GNOME or standard Ubuntu-GNOME (your release of Ubuntu could be a huge start, plus letting us know if you've added any extensions which change behavior)
    – guiverc
    Aug 1, 2019 at 23:51
  • Very sorry about that. Ubuntu 18.04.2. I don't think I've added extensions, just let it update a few times and added some programs like a video player and things like that.
    – P Simdars
    Aug 2, 2019 at 0:30

1 Answer 1


The always visible "favourites bar" is provided by the GNOME shell extension Ubuntu Dock (package name: gnome-shell-extension-ubuntu-dock). As per GNOME's security policy, whenever your system is suspended (goes to sleep), all the extensions get disabled automatically until you get back in, and then the extensions get re-enabled. Somehow it's failing here for the Ubuntu dock extension in your case.

As a temporary workaround either restart your system (or log out and log in again) or simply restart GNOME shell by pressing Alt+F2, then typing r, and finally hitting Enter.

  • This works great. Thank you.
    – P Simdars
    Aug 5, 2019 at 13:28
  • 1
    @PSimdars If you find this answer useful, you may consider "accepting" it (by clicking the tick (✓) next to it) to indicate you've found a working solution and also so that others may more easily find it in the future.
    – pomsky
    Aug 5, 2019 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.