5

After opening more than 800 pages long docx document in Writer 6.2.5.2, response is very slow. The document consists mainly of text. My version of Ubuntu is 16.04.

I tried to find enhancement of memory, but unsuccessfully. I managed to disable the Java runtime in: Tools → Options → LibreOffice → Advanced → "Use a Java Runtime environment", but it does not have visible effect.

Is there any improvement or workaround or is it just normal? In my search I found at best older versions of LibreOffice.

Update 1: Writer does not get stuck but every editation takes much time. Currently process soffice.bin takes around 450 MB RAM, though my RAM is 8GB and I set TotalCacheSize to 900 MB. One of my 4 cores is usually running on 100%.

  • 3
    Read man mkswap;man swapon and add swap space, I'd suggest 2 x System RAM to start. Watch free to see memory/swap availability. – waltinator Aug 1 '19 at 21:15
  • 1
    Is Libreoffice Writer stuck or 'only' very slow? -- The radical solution is to buy more RAM, but it costs money. An alternative is to use Lubuntu instead of standard Ubuntu because Lubuntu uses less RAM for the system (the main difference is the graphical desktop environment). So there will be more RAM available for Libreoffice Writer. You might also try abiword which is a lighter word processor (that comes with Lubuntu. – sudodus Aug 1 '19 at 22:00
  • Response to Update 1: One of the cores is running on 100%. It is possible that CPU power is the limiting factor, that conversion from docx takes a lot of CPU power, and there is no parallel processing. Does it work faster to open (and write) an ODT version of the same document? – sudodus Aug 3 '19 at 11:11
3

There are a memory settings buried deep in the menu structure of LibreOffice which you might wish to experiment with at your own risk.

Specifically, in Options → LibreOffice → Advanced, click Open Expert Configuration; in the dialog, navigate to org.openoffice.Office.Common/Cache.

screenshot showing Options - LibreOffice - Advanced

Then in the search box enter org.openoffice.Office.Common/Cache to navigate to the screen below:

screenshot showing Expert Configuration

after which you will be able to adjust the settings. Note that these values are in bytes.

LibreOffice themselves say that

There's no "acceptable" values, only trial and error may help you. Or may not: the settings control very specific area in memory management. In most aspects, LibreOffice doesn't need any adjustments to just consume all available

Reference

Adding more memory may well be the best option in this case.

Alternatively if changing the memory settings in LibreOffice has no effect, it may be necessary (with v16.04) to consider the size of your swap partition.

the table below may give some guidance here:

enter image description here For your 8Gb Ram it recommends a swap size (without hibernation) of 3Gb and if you are using hibernation 11Gb.

2nd Reference - swap size

| improve this answer | |
  • I tried to change Cache settings, but it has not visible effect. I changed from 200 MB to 900 MB though, it does not seem that soffice.bin takes so much memory. – weatherman Aug 3 '19 at 10:37
  • @weatherman I've researched further and added some more information about swap size which you might find useful. – User24601 Aug 3 '19 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.