1

I would like to install the latest Ubuntu (19.04) on a ThinkPad X1 Extreme Gen 2. I have read about some issues with installing previous versions of Ubuntu on the Gen 1, ie the BIOS update, but I'm unable to find anything related to the latest Ubuntu and/or the X1 Extreme Gen 2.

I know it's only been a few weeks since the Gen 2 came out, but has anyone done the same? Does anyone see any red flags that I should know about? Any advice or assurance would be much appreciated, since this will be my first time installing Ubuntu (and Linux in general).

  • You can try Ubuntu before installing may help you! Reference: tutorials.ubuntu.com/tutorial/try-ubuntu-before-you-install#0 – Razor Rassh Aug 1 at 19:14
  • Thanks @RazorRassh! I will run from USB and test it out before installing. – Ryan Christoffersen Aug 1 at 19:18
  • Tried. Wifi does not work. :-( any solution? – kctang Aug 30 at 11:04
  • No solutions. I am unable to get the wifi working as well. I have been tethering with my phone for the time being. I'm also unable to get the NVIDIA Graphics properly installed but it looks like the next update with kernel 5.2 will resolve this. – Ryan Christoffersen Sep 1 at 10:41
  • 1
    After updating to 19.10, everything seems to be running smoothly. WiFi is working and NVIDIA Graphics is properly installed. – Ryan Christoffersen Oct 30 at 6:13
3

I received my Extreme Gen 2 on the October 31st 2019, I did not install Ubuntu 18.04 because I would not be able to upgrade the kernel version without WiFi since I don't have Ethernet port.

Consequently I installed Ubuntu 19.10 (kernel 5.3), disabled Secure Boot, Windows fast startup and blacklisted the NVIDIA Nouveau driver to replace it by the proprietary NVIDIA Driver. Now everything works even Docker.


Here are the steps to install it along Windows:

  • Disable Windows 10 fast startup because when it is enabled, your computer doesn’t perform a regular shut down: instead it builds hibernation files that you want avoid when dual-booting.

  • Update UEFI/BIOS to 1.26 (initially my UEFI/BIOS was up to v1.17) since old UEFI/BIOS contain multiple bugs that can result in bricking the laptop. You can perform it using the Lenovo Vantage app under Windows 10.

  • Disable Secure Boot: it is a verification mechanism for ensuring that code launched by a computer’s UEFI firmware is trusted. The issue is that NVIDIA Drivers are not signed hence Secure Boot would interrupt the boot process.

  • Install Ubuntu by hitting Enter on startup and selecting your bootable USB stick. Now you have Ubuntu installed on your laptop but it crashes when loading the default Ubuntu’s Nouveau NVIDIA Driver. Consequently we will blacklist it and installing the NVIDIA proprietary driver which works fine.

  • Reboot the computer. In the GRUB menu press E to edit the command before booting then append ‘nomodeset’ at the end of the ‘linux…’ line : it will prevent the system from loading graphics drivers hence we will be able to install NVIDIA drivers and blacklisting the Nouveau driver. Don’t worry, ‘nomodeset’ will only be effective for that session.

  • Install last NVIDIA proprietary driver.

  • Blacklist Nouveau driver to avoid conflicts.

Now the NVIDIA proprietary drivers are installed on your system and the open-source Nouveau driver is blacklisted so no conflicts between graphics drivers should happen.

These instructions come from the Medium article I wrote (https://medium.com/@remy.hosseinkhan/installing-ubuntu-19-10-on-lenovo-thinkpad-x1-extreme-gen-2-and-p1-gen-2-ba4c9c7c7ed2) check it if you have trouble to solve one step. I've looked at several threads in order to understand what goes wrong with installing Linux on this laptop : the main issue comes from the NVIDIA Optimus technology that is still causing trouble nowadays (see Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?).

New contributor
Rémy Hosseinkhan Boucher is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 3
    Excessive promotion of a specific product/resource may be perceived by the community as spam. Take a look at the help center, specially What kind of behavior is expected of users?'s last section: Avoid overt self-promotion. You might also be interested in How to not be a spammer and How do I advertise on Stack Overflow?. – Machavity Nov 6 at 18:28
  • I am sorry ! What about if I copy what I wrote on medium ? This thread helped me a lot to write it I just wamted to help. @Machavity – Rémy Hosseinkhan Boucher Nov 6 at 18:43
  • 1
    @RémyHosseinkhanBoucher You could even still link to your post on Medium; but please make sure it's explicitly clear, in your answer here on Ask Ubuntu, that it's your post. With that said, yes, it would be excellent if you would include the full text in your answer here. That ensures this answer is complete and self-contained and that it can keep helping readers even if your Medium post goes offline or ends up changing in the future. If you're willing to make this answer self-contained by including all (or the relevant parts) of the article you wrote in the answer, that would be great! – Eliah Kagan Nov 6 at 18:51
  • Thank you @Machavity and EliahKagan I will try to answer properly now:) – Rémy Hosseinkhan Boucher Nov 6 at 18:56
1

I got an X1 Extreme Gen 2 a week ago. And it's been pretty much awful.

Up to kernel 5.3.0-18 the wifi either didn't work, or the system would panic on boot trying to read the tpm logs (No, I didn't fancy turning off secure boot because then I found windows wouldn't start)

Having solved the wifi issue via kernel 5.3.0-18 the system now has a 50% chance of locking up on login. Or an 80% chance of locking up on wake from sleep.

Then there's the overheat messages. The system will throttle and log mce: overheat messages while stone cold immediately after boot.

I'd struggle to recommend one. TBH I think I made an expensive mistake and should have stayed with the far more expensive and inflexible 2019 MacBook Pro.

  • 1
    It's possible that the hang after boot and after resume are due to the Nvidia drivers. At least that's where the errors in the dmesg output suggest. – Hamish Oct 20 at 12:19
  • Oh.. Add in that the keyboard and touchpad are fairly insensitive compared to the MBP (Late 2013) as well. – Hamish Oct 20 at 13:58
  • Everything is running smoothly for me now after updating to 19.10. I was also torn between the latest MacBook Pro or the latest ThinkPad X1. I had been somewhat uncertain about my decision until recently updating to 19.10. – Ryan Christoffersen Oct 30 at 6:17
  • @Hamish How disappointing. I was not satisfied at all with the Yoga X1 2nd Gen, that I started to do some research for a new notebook. I hoped to see that X1 Extreme 2nd Gen would have fixed all those issues :-( In this post I've tried to solve the CPU throttling issues, with no success: askubuntu.com/questions/1013225/… – Christopher Will Nov 5 at 20:53
1

As I just got a Lenovo ThinkPad X1 Extreme Gen 2 today and immediately wiped the drive and tried to install Ubuntu and ran into some problems I thought I'd offer my solution (which wasn't possible at the time of OP's post, but from the comments they seem to have also come to) in the event that someone like me might need a much more detailed explanation.

I originally tried to install Ubuntu 18.04.3 LTS but soon found that there was no Wi-Fi adapter found at all. After checking the X1's tech specs again I searched on "Intel AX200 Wi-Fi 6 802.11AX" and found the Linux* Support for Intel Wireless Adapters page which listed the Intel Wi-Fi 6 AX200 160MHz as needing a Linux kernel release of 5.1+. As uname -r showed that 18.04.3 had 5.0, after checking the Ubuntu releases it was clear that (in October of 2019) the only viable option was Ubuntu 19.10 (as it had kernel 5.3). Doing a clean install of 19.10 immediately fixed the Wi-Fi problem, but then during the gnome-initial-setup (Welcome to Ubuntu) the entire OS would freeze up. I noticed that before continuing with the gnome-initial-setup that if I looked around in settings that I found that the default graphics driver being used was the Nouveau and not the Nvidia (proprietary, tested) driver. If the Nvidia driver was switched to and then the gnome-initial-setup was run it would complete without issue and the computer was finally ready for use.

While I now quite happy so far with Ubuntu 19.10 and the Lenovo ThinkPad X1 Extreme Gen 2, I am certainly looking forward to the 20.04 LTS release in 2020.

  • Thanks for providing more detail. As mentioned, updating to 19.10 and switching to the Nvidia (proprietary, tested) driver worked for me. – Ryan Christoffersen Nov 1 at 4:36
  • Does 19.04 affect suspending the laptop, as in does it go to sleep correctly? Are there any other problems after installing 19.04? – Rohan Nov 3 at 20:42
0

I installed pop os (which is more similar to Ubuntu). Everything works fine out of the box except wifi. I have to update kernel version from 5.0 to 5.2. After that all good.

  • 1
    @SAGA I know it's been a couple months since you posted this answer, but would you be willing to edit it to expand it with details about you installed kernel version 5.2? – Eliah Kagan Nov 6 at 2:11
0

The Nvidia GPU didn't get detected for me on Ubuntu 19.04. I tried Ubuntu 18.04.3 and everything worked - just had to install kernel 5.2 to get wifi working.

Note however, that the battery lasts less long than it does on Windows - even after TLP, turning off turbo boost, running in powersave mode and setting lowest frequency to 800Mhz. Fans turn on more than in Windows despite CPU frequency being at at 800Mhz and nvidia GPU being turned off - so I'm guessing the intel GPU always runs at its max frequency (I couldn't figure out how to reduce its frequency).

  • I tried updating the kernel to 5.2.15 on Ubuntu 19.04 using Ukuu. Caused problems. First I couldn't boot at all. I disabled Secure Boot in the BIOS per this post askubuntu.com/questions/1115010/…. Then it booted and I'm able to log in, but everything freezes shortly after boot and I have no recourse but to hard boot. Currently trying to get the grub menu up to run in recovery mode and switch the kernel back :(. – m4olivei Sep 18 at 3:34
  • I ended up getting things to work by updating to the latest Linux 5.1 kernel (5.1.21). After that, I also had to install the Intel AX200 Wireless LAN firmware found here intel.com/content/www/us/en/support/articles/000005511/… – m4olivei Sep 18 at 13:12
0

I just got my X1 extreme Gen 2. I have installed a dual boot system with Windows 10 and Ubuntu 19.04, but had problem with Wi-Fi, HDMI output, and the fingerprint reader.

The Wi-Fi problem has been solved with installing last iwlwifi Linux driver. HDMI and the fingerprint reader are not working yet. It seems no linux driver is available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.