I just got my PC back from the service where they changed the power supply. Probably that changed the setup for the dual boot I have already set up. I have installed Windows 10 and Ubuntu. When I tried to start the PC, in the grub menu there is only Ubuntu and not Windows. Tried to fix it with boot-repair but it didn't work. Here is the link from boot-repair

I have tried update-grub, editing the custom_40 file with:

menuentry "Windows 10" --class windows --class os {
   insmod ntfs
   search --no-floppy --set=root --fs-uuid $your_uuid_here$
   ntldr /bootmgr

with the correct uuid. Windows 10 appeared as an option but when I enter it shows the errors:

file '/boot/grub/x86_64-efi/ntfs.mod' not found

file '/boot/grub/x86_64-efi/ntldr.mod' not found
can't find command 'ntldr'

Can anyone help me?

  • @karel yes i already read that. But the guy there had win8 and win10 in his system. Also i have done the obvious update-grub and adding the commands in the replies in the custom_40 file but none of these worked :/ – Miltos Taramanidis Aug 1 at 12:41
  • @karel tried the commands in the answers but again an option is created but i'm missing some files – Miltos Taramanidis Aug 1 at 13:00
  • 1
    You need to boot in legacy-mode, that's all. Enter your UEFI-settings and choose correct boot device, dont choose the ubuntu-entry, that's for EFI-mode, instead boot to your HDD, then grub will open, choose ubuntu then and run sudo update-grub again. You have an obsolete boot-loader for ubuntu on your drive which will boot in efi-mode, but grub is also in MBR. – mook765 Aug 1 at 13:21
  • @mook765 oh god it was easier than i expected. Thank you! – Miltos Taramanidis Aug 1 at 13:35
  • Would you please mind to provide an answer by yourself, I'd give it an upvote. – mook765 Aug 1 at 13:38

As suggested by @mook765 all I had to do was to change the boot order and make boot option #1 from hard drive and not Ubuntu. With that way Windows loaded with no problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.