In Java class, my sir told me to link Tomcat server config which is inside Xampp folder. But his OS was Windows and things were different on my side since I use Ubuntu 19.04. I installed "xampp-linux-x64-7.3.7-1-installer.run" from their Official website.

But unfortunately, there is no such "Tomcat" folder like in my sir Windows OS.

So I installed Tomcat using "sudo apt install tomcat9" assuming its the latest stable built.

And I went to Intellij to add Tomcat's local server configuration, and showed the path "/etc/tomcat9" but the IDE says "Application server libraries not found" as u can see in the screenshot below:

screenshot of an error

What to do? What am I missing? Help needed.


The solution to this problem is putting:

  • /usr/share/tomcat9 in Tomcat_Home.

  • /var/lib/tomcat9 in Tomcat base directory.

As seen in the screenshot below.


Note: Apparently, it is very important to add Artifacts in the 'Deployment' section and apply it. Like this: Screenshot to where to go and add artifact

  • 1
    I know the problem has been solved, but I just want to add something in case other people come across this forum. If you get an "Error running 'Tomcat 9.0.31 (Ubuntu)': Address localhost:8080 is already in use" just go to "Edit Configurations..." below "Tomcat Server Settings" change the HTTP port from 8080 to whatever port is free (8088 for example)
    – Hydro
    Feb 24 '21 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.