Opera Browser failed to appear in Ubuntu software (it was there 6 months ago!) so I found a download elsewhere. In configuring Opera I was prompted to upgrade to activate vpn. Doing so only installed another version or basically caused a multiple configuration. I noticed this in the terminal when completing sudo apt-get update. I have tried autoremove, which does not change multiple configuration. How can I fix this? Please be patient I am after all only a novice to Linux and Ubuntu.


The configurations are going to be in ~/.config/opera. I would purge everything and start over (from the terminal):

sudo apt-get purge opera
sudo rm /etc/apt/sources.list/opera-stable.list
sudo apt-get update
rm -rf ~/.cache/opera ~/.config/opera

Now, you can download the latest version from https://www.opera.com and you should be good to go.

  • When I run the first command line suggested the output says opera was never installed, which is not correct opera is indeed installed still works (not that well) and is still in my applications. @ajgrino619 Aug 1 '19 at 6:33
  • OK, if was truly installed, what does apt-get search opera return? Aug 1 '19 at 14:51
  • Sorry, I used the wrong syntax. It should be aptitude search opera (probably have to install that first). Aug 1 '19 at 23:26

I had opera-stable installed. not opera. I was able to uninstall opera stable by going back to the opera website. I was able to reinstall opera stable from there. So I hope everything was done correctly!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.