1

I am new in Linux and I am trying to install Ubuntu 18.04 LTS in my laptop with a Dual Boot with Windows 10. My laptop is an Asus with 4GB RAM, 1TB HDD, and 16GB Intel Optane. The problem is that Ubuntu doesn't show any partition of Windows, neither the HDD. It only shows the Kingston USB. I'm adding links to images with what happens and when happens.

  • This is what happens when I restart my laptop and I try to install Ubuntu from my Kingston USB. It doesn't show the HDD, and it only shows my 4GB USB. This happens in the option "Try Ubuntu without installing" and in the option "Install Ubuntu" directly.

    Screenshot 1 Screenshot 2

  • These are some things that appear in the BIOS configuration, like the option to change the SATA Mode Selection. Here I change the SATA Mode Selection from "Intel RST Premium With Intel Optane System Acceleration" to AHCI. Here are some photos of the SATA ports and the Boot option. But I have only changed the SATA Mode Selection.

    enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

  • After changing the SATA Mode Selection, if I try to start my laptop with Windows 10, it gives me an error, and at the moment of trying to install Ubuntu, it shows the USB and also shows my 16gb Intel Optane. But it still doesn't show the HDD.

    enter image description here enter image description here

  • Here is a picture with my laptop specs and the website where I have bought the laptop.

    enter image description here

I would be very grateful to anybody that could help me to install Ubuntu. I haven't found a lot of information about this problem with Optane and Ubuntu.

3
  • 1
    You have to first add AHCI drivers into Windows for Windows to work with AHCI mode. Intel Optane - See Intel response that no performance difference between RAID & AHCI. communities.intel.com/thread/121155 & askubuntu.com/questions/1134503/… Many also have had to update UEFI & SSD firmware.
    – oldfred
    Jul 31 '19 at 18:01
  • @oldfred Do you know if there is a tutorial easy to understand to add AHCI drivers to Windows 10? I have found one, but I don't know if is the correct solution for my problem, and I am afraid that I could break my Windows if I don't do it correctly.
    – bryan-gc
    Aug 1 '19 at 17:11
  • 1
    This is an Ubuntu question & answer site. I never had to add AHCI drivers to Windows so do not know. Best to ask on Windows site or superuser.com if not sure of instructions you found. Also this which has a couple of ways: askubuntu.com/questions/1148120/…
    – oldfred
    Aug 1 '19 at 18:41
1

you should disable optane in windows (with the intel program in windows). then you will be able to install ubuntu in dual boot.

Then any time you want to use ubuntu, you have to disable optane in windows (wich will run slowly then) before booting ubuntu.

this works fine with me

2
  • Hi, if i do this my linux distro will not have nothing of optane features i guess? How can I use these features in some Linux distro? Nov 1 '19 at 19:40
  • This answer is only slightly correct (disable Optane which is incompatible). But then it contains a false statement about Windows and completely ignores the correct comments already here one year or so ago about enabling AHCI and installing AHCI support in Windows. Jun 16 at 16:40
0

The main problem is with detecting an Intel Optain hard disk which is not supported with generic drivers. Reinstallation of OS is required to change SATA mode. If you don't want to reinstall the whole OS this may be a workaround. You may try to enable AHCI SATA mode for Windows, then try to install other OS(ubuntu in your case). So GRUB will be able to create a boot entry for both OS by the end of the installation. After finishing the installation doesn't Forget to disable AHCI mode from BIOS setting otherwise it will result in a Blue screen error as in your case.

1
  • 1
    This answer is partially correct. It identifies the incompatible Optane/Intel RST and recommends AHCI. So far so good. What should come next is informing the OP that AHCI support must be installed in Windows, not to change modes back and forth. Jun 16 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.