2

I was trying to create a persistent storage on a Live Ubuntu USB drive. Then I came to many tutorials that required mkusb. I've searched for many ways to install it but I couldn't, even after adding PPAs, restarting, editing sources.list, etc. This is the output:

$ sudo add-apt-repository ppa:mkusb/ppa

 More info: https://launchpad.net/~mkusb/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://ppa.launchpad.net/mkusb/ppa/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease        
Hit:3 http://vn.archive.ubuntu.com/ubuntu bionic InRelease
Hit:4 http://vn.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:5 http://vn.archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done

$ sudo apt update                      
Hit:1 http://ppa.launchpad.net/mkusb/ppa/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Hit:3 http://vn.archive.ubuntu.com/ubuntu bionic InRelease
Hit:4 http://vn.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:5 http://vn.archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

$ sudo apt install mkusb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package mkusb

I don't know if I made some mistakes somewhere. Thanks!

EDIT: I managed to install mkusb using tarball, but it doesn't detect my USB drive. But the main point is finished, maybe I will ask another question. Thank you!

  • 1
    Wish they would add mkusb to Ubuntu Software Center. – C.S.Cameron Jul 31 '19 at 17:14
  • Which linux distro and version are you running? Your output indicates Ubuntu Bionic alias 18.04 LTS, but maybe you are running some 're-spin' (distro developed from Ubuntu Bionic)? Is your Ubuntu up to date? Try sudo apt upgrade -- Or maybe threre was a temporary error, that prevented your computer 'to locate package mkusb'. – sudodus Jul 31 '19 at 17:27
  • An alternative is to install mkusb-dus via the instructions at this link – sudodus Jul 31 '19 at 17:44
  • @sudodus It's original Ubuntu 18.04 LTS. And it's up to date at the time of question. – Binh T. Nguyen Aug 1 '19 at 1:11
  • @sudodus I hope you will make an answer, so I can accept it. I also edit my question, thank you! – Binh T. Nguyen Aug 1 '19 at 3:14
0

The standard method to install mkusb is via the PPA

If you run standard Ubuntu live, you need an extra instruction to get the repository Universe. (Kubuntu, Lubuntu ... Xubuntu have the repository Universe activated automatically.)

sudo add-apt-repository universe  # only for standard Ubuntu

sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi

Alternative method via tarball

If for some reason it does not work with the PPA, you can install mkusb via a tarball according to the following link,

help.ubuntu.com/community/mkusb/gui/tarball

| improve this answer | |
3

Try adding the PPA again with the following command:

sudo add-apt-repository ppa:mkusb/ppa

I didn't see any keys being imported in the log you posted.

It should look something like this:

You are about to add the following PPA to your system:
 More info: https://launchpad.net/~mkusb/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.moYjnLh1cS --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 54B8C8AC
gpg: requesting key 54B8C8AC from hkp server keyserver.ubuntu.com
gpg: key 54B8C8AC: "Launchpad PPA for MKUSB" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

Next, update and install the package with the following commands:

sudo apt update
sudo apt install mkusb
| improve this answer | |
  • Thanks, but I added 10 times, more or less. But it didn't work. – Binh T. Nguyen Jul 31 '19 at 11:28
  • 1
    Is that ppa added in your sources.list? – Tomáš Tomovčík Jul 31 '19 at 12:12
  • Yes, it's inside sources.list. When I tried to manually add it again, running add-apt-repository warned me about duplicate sources in sources.list – Binh T. Nguyen Aug 1 '19 at 1:10
  • But I don't understand why my output is different from yours! – Binh T. Nguyen Aug 1 '19 at 1:14
  • Dunno. Might seem odd, but try maybe reinstalling apt itself. Download latest deb package for your version and install it with 'dpkg -i <package_name>.deb' – Tomáš Tomovčík Aug 1 '19 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.