0

when i run `apt-get update it shows the following error message


Err:6 http://in.archive.ubuntu.com/ubuntu bionic-backports Release 
404  Not Found [IP: 192.168.3.1 80] 
Reading package lists... Done     
E: The repository 'http://in.archive.ubuntu.com/ubuntu bionic Release' does not have a Release file. 
N: Updating from such a repository can't be done securely, and is therefore disabled by default. 
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://in.archive.ubuntu.com/ubuntu bionic-updates Release' does not have a Release file. 
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
  • There are no line-breaks in what you pasted, and it makes it hard to read. But either way 192.168.x.x is not an address that can be routed externally, so you have a networking/firewall/proxy issue; are you at a uni or somewhere with strict network rules? Because of the bad formatting it's hard to see which line got translated into 192.168 (or a local address) – guiverc Jul 31 at 7:29
  • @guiverc .. I have thrown in a handfull of line-breaks ... – Soren A Jul 31 at 7:58
  • Possible duplicate of How do I restore the default repositories? – N0rbert Jul 31 at 10:40
  • @N0rbert i dont think so – Vignesh A Jul 31 at 11:13
  • Do you know your network structure? What is on 192.168.3.1 ? Also please add output of sudo grep -r "192.168.3.1" /etc/apt and sudo grep -ir proxy /etc/apt to the question. – N0rbert Jul 31 at 11:30
0
  • Are you using any proxy or VPN? Prolly a PiHole. If yes, try disabling them.
  • In your sources.list there's usually a space after https:// - try checking it.

Sources:

Ubuntu repository does not have a Release file

Bionic Default Repositories do not have release file - sudo apt-get update not working

  • No i am not using any proxy or vpn and i double checked the sources.list it seems to be correct – Vignesh A Jul 31 at 7:22
  • I don't know that much about networks, but that IP doesn't seem right. When I pinged that host, this is the IP I got: 103.123.234.254. Correct me if I'm wrong, but that seems like the issue is on your side. Did you change some settings recently? – Tomáš Tomovčík Jul 31 at 7:27
  • i changed my ip 2 days ago does this cause the problem? – Vignesh A Jul 31 at 7:30
  • Well there you go. What do you mean by changed? Using static or messed up with hosts file? Try reverting those changes if possible and try updating again. – Tomáš Tomovčík Jul 31 at 7:31
  • my company changed my ip for monitoring my network so i cant change the ip is there any other way? – Vignesh A Jul 31 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.