1

I've been trying to upgrade my home theater PC from Mythbuntu 16.04 (the last release of Mythbuntu) for the past few months. I perform a "do-release-upgrade" and I get this:

Reading state information... Done
Restoring original system state
Aborting
Reading package lists... Done    

I can't figure out why it's aborting, other than there is no such release Mythbuntu 18.04. I'm not seeing anything in the log files indicating why it aborted. I also removed all the PPAs I had (e.g. mediatree).

Looks like I'll have to start clean with Ubuntu 18.04 and then install MythTV on top of that. I was hoping to avoid that, but it looks like I have no other choice, except to hold off on the upgrade.

[Updated 08/01/19] Added command and full output, along with output from apt list, per request.

jim@goldchannel:~$ sudo do-release-upgrade --mode=desktop
[sudo] password for jim: 
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]                                           
Get:2 Upgrade tool [1,240 kB]                                                  
Fetched 1,241 kB in 0s (0 B/s)                                                 
authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg' 
extracting 'bionic.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Hit http://us.archive.ubuntu.com/ubuntu xenial InRelease                       
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]     
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]    
Get:3 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]  
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [1,
000 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [845
 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [758 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [691 kB]
Fetched 3,619 kB in 0s (0 B/s)                                                 
Reading package lists... Done    
Building dependency tree          
Reading state information... Done

Restoring original system state

Aborting
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
jim@goldchannel:~$ apt list --installed | grep hw

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

hwdata/xenial-updates,xenial-updates,now 0.267-1ubuntu2 all [installed,automatic]
lshw/xenial-updates,now 02.17-1.1ubuntu3.6 amd64 [installed]
mythweather/now 2:0.28.2+fixes.20180827.9031599-0ubuntu0mythbuntu2 amd64 [installed,local]
mythweb/now 2:0.28.2+fixes.20180827.9031599-0ubuntu0mythbuntu2 all [installed,local]
python-debtagshw/xenial,xenial,now 2.0.1ubuntu6 all [installed]

And output from uname -a and lsb_release -a.

jim@goldchannel:~$ uname -a
Linux goldchannel 4.4.0-143201903221420-generic #0+mediatree+hauppauge-Ubuntu SMP Fri Mar 22 23:58:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

jim@goldchannel:~$ lsb_release -a
LSB Version:    core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.6 LTS
Release:    16.04
Codename:   xenial

[Updated 8/3/19] Added dpkg -l | grep recover, per nobody's request. (And took out extra spaces for readability.)

jim@goldchannel:~$ dpkg -l | grep recover
ii  foremost           1.5.7-6                amd64        forensic program to recover lost files
ii  friendly-recovery  0.2.31ubuntu2.1        all          Make recovery more user-friendly
ii  gddrescue          1.19-2                 amd64        GNU data recovery tool
ii  scalpel            1.60-3                 amd64        fast filesystem-independent file recovery
ii  testdisk           7.0-1                  amd64        Partition scanner and disk recovery tool, and PhotoRec file recovery tool

[Updated 8/8/19] Added log file /var/log/dist-upgade/20190808-2242/main.log.

2019-08-08 22:38:12,314 INFO Using config files '['./DistUpgrade.cfg.xenial']'
2019-08-08 22:38:12,314 INFO uname information: 'Linux goldchannel 4.4.0-1432019
03221420-generic #0+mediatree+hauppauge-Ubuntu SMP Fri Mar 22 23:58:32 UTC 2019 
x86_64'
2019-08-08 22:38:12,717 INFO apt version: '1.2.32'
2019-08-08 22:38:12,717 INFO python version: '3.5.2 (default, Nov 12 2018, 13:43
:14) 
[GCC 5.4.0 20160609]'
2019-08-08 22:38:12,722 INFO release-upgrader version '18.04.34' started
2019-08-08 22:38:12,804 INFO locale: 'en_US' 'UTF-8'
2019-08-08 22:38:13,294 DEBUG Using 'DistUpgradeViewGtk3' view
2019-08-08 22:38:13,343 DEBUG enable dpkg --force-overwrite
2019-08-08 22:38:13,370 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clo
ne_system_state.tar.gz'
2019-08-08 22:38:19,743 DEBUG lsb-release: 'xenial'
2019-08-08 22:38:19,744 DEBUG _pythonSymlinkCheck run
2019-08-08 22:38:19,748 DEBUG openCache()
2019-08-08 22:38:19,748 DEBUG No such plugin directory: ./plugins
2019-08-08 22:38:19,748 DEBUG plugins for condition 'PreCacheOpen' are '[]'
2019-08-08 22:38:19,748 DEBUG plugins for condition 'bionicPreCacheOpen' are '[]
'
2019-08-08 22:38:19,748 DEBUG plugins for condition 'from_xenialPreCacheOpen' ar
e '[]'
2019-08-08 22:38:19,748 DEBUG quirks: running PreCacheOpen
2019-08-08 22:38:19,748 DEBUG running Quirks.PreCacheOpen
2019-08-08 22:38:20,456 DEBUG /openCache(), new cache size 89519
2019-08-08 22:38:20,457 DEBUG need_server_mode(): run in 'desktop' mode, (becaus
e of pkg 'ubuntu-desktop')
2019-08-08 22:38:20,457 DEBUG checkViewDepends()
2019-08-08 22:38:20,457 DEBUG running doUpdate() (showErrors=False)
2019-08-08 22:38:21,608 DEBUG openCache()
2019-08-08 22:38:22,391 DEBUG /openCache(), new cache size 89519
2019-08-08 22:38:22,391 DEBUG doPostInitialUpdate
2019-08-08 22:38:22,392 DEBUG plugins for condition 'PostInitialUpdate' are '[]'
2019-08-08 22:38:22,392 DEBUG plugins for condition 'bionicPostInitialUpdate' ar
e '[]'
2019-08-08 22:38:22,392 DEBUG plugins for condition 'from_xenialPostInitialUpdat
e' are '[]'
2019-08-08 22:38:22,392 DEBUG quirks: running bionicPostInitialUpdate
2019-08-08 22:38:22,392 DEBUG running Quirks.bionicPostInitialUpdate
2019-08-08 22:38:27,411 DEBUG abort called
2019-08-08 22:38:27,412 DEBUG openCache()
2019-08-08 22:38:28,181 DEBUG /openCache(), new cache size 89519

[Updated 8/12/19] Added the output of dpkg --print-architecture.

amd64

[Updated 8/15/19] Added output of snap list, per request of nobody. Also added output of uname -a.

jim@goldchannel:~$ snap list
error: cannot list snaps: cannot communicate with server: Get http://localhost/v2/snaps: dial unix /run/snapd.socket: connect: no such file or directory

jim@goldchannel:~$ uname -a
Linux goldchannel 4.4.0-157-generic #185-Ubuntu SMP Tue Jul 23 09:17:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[Updated 8/18/19] Adding output from systemctl status snapd.socket and contents of /etc/apt/sources.list.d.

 jim@goldchannel:~$ systemctl status snapd.socket
Failed to get properties: No such interface '' 

jim@goldchannel:~$ sudo ls /etc/apt/sources.list.d
b-rad-ubuntu-kernel_mediatree_hauppauge-xenial.list
heyarje-ubuntu-makemkv-beta-xenial.list
mythbuntu-testing-trusty.list
mythbuntu-ubuntu-0_27-xenial.list
mythbuntu-ubuntu-0_28-xenial.list
plexmediaserver.list
ubuntu-audio-dev-ppa-trusty.list

[Updated 8/19/19] I looked at the dist-update log and it seems to gag and blow chunks after the line "quirks: running bionicPostInitialUpdate". Can't find any more detailed info after that, but it appears I'm not the only one having this problem. Refer to Unable to upgrade from 16.04 to 18.04, no real error?

4
  • Can you show us the command + full output. also apt list --installed | grep hw Please edit your question for that. – nobody Jul 31 '19 at 6:22
  • Certainly. I just added it to the original post. I also added output from uname -a and lsb_release -a. – poltr1 Aug 2 '19 at 1:31
  • dpkg -l | grep recover please. – nobody Aug 2 '19 at 8:06
  • Done; added to the post. – poltr1 Aug 4 '19 at 0:11
0

This is an error with snaps. systemctl status snapd.socket

snap list
No snaps are installed yet. Try 'snap install hello-world'.` 

this is the message you get, if you have no snaps on your system.

remove it. sudo apt purge snapd

 sudo apt update && sudo apt full-upgrade

Try again. Be attentive during the upgrade, in bionic is gnome3 the new default desktop. Backup your data.

7
  • I'm aware of that. The Hauppauge tuner card required a fork of the standard kernel. I rebooted, selected the standard kernel, typed both steps above, and then attempted a do-release-upgrade. Still aborted, as it did above. – poltr1 Aug 9 '19 at 2:48
  • dpkg --print-architecture please. – nobody Aug 9 '19 at 9:20
  • It's "amd64". Added to the main post. – poltr1 Aug 13 '19 at 1:43
  • snap list please. – nobody Aug 13 '19 at 8:09
  • Added. Not sure how this will help. I don't use snaps. – poltr1 Aug 16 '19 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.