3

Please forgive me if I don't give enough detail. I am a new user. I recently tried to install GIMP (photo-editor) using the terminal and I think it required me to install flatpak which I don't really understand and shouldn't have installed it I guess, because now I can't do what I could before. I have since uninstalled flatpak but still have same problem.

Earlier, when I was using dpkg --list to get the name of a program I wanted to uninstall, I could see a full list of all installed programs. Now I just get this weird list that doesn't look like programs, and it starts in alphabetical order but only starting at the letter "L", e.g.

libgphoto2-6:a 2.5.16-2 amd64 gphoto2 digital camera library

is the first entry. And then,

zlib1g:amd64 1:1.2.11.dfs amd64 compression library - runtime

is the last entry.

It doesn't seem to be listing programs. Like, I have clementine installed and its no longer listed with that command. I am so confused.

To give another example, I installed and uninstalled a media player successfully earlier today using the terminal, using dpkg --list to determine said program's name. I can no longer see any real programs using this or similar commands I have found here.

EDIT: apt list --installed gives the same stupid incorrect list.

Maybe it's showing libraries instead of programs now??

  • 2
    my dpkg --list seems to work ok. What version do you have? Mine is: $ apt list dpkg Listing... Done dpkg/xenial-updates,now 1.18.4ubuntu1.5 amd64 [installed] N: There is 1 additional version. Please use the '-a' switch to see it – WinEunuuchs2Unix Jul 31 '19 at 1:57
  • I'm using Xubuntu. I typed the command you put there and it says my version is 1.19.0.5ubuntu2.1 I'm not sure my version is the problem. I think something bad happened when I tried to manually install gimp (flatpak?) because the dpkg --list thing worked before I did that. – Tenacious Qi Jul 31 '19 at 2:02
  • Probably you want to use snap list? This would work for snaps. Snaps and flatpaks are not managed with dpkg, for flatpacks use flatpak list. – mook765 Jul 31 '19 at 3:10
  • The only snap I had was spotify. Clementine wasn't a snap I don't think. I just did a clean reinstall of linux and the dpkg list still only starts with programs that start with the letter "l" as in libre. Is that what everyone elses starts with? I know I have programs that start with earlier letters...? – Tenacious Qi Jul 31 '19 at 3:38
  • 1
    Have you tried using dpkg -l | grep clem to search for something like "clem" or dpkg -l | less to ensure that your list is not truncated (type "q" to exit less)? – mchid Jul 31 '19 at 10:43
2

I think that the problem lies in the terminal output configuration. Chances are that it is configured so that it shows 1000 lines, while the output of dpkg --list or apt list --installed is more than 1000 lines.

In your terminal's preferences change the number of scrollback lines from 1000 to 10000 and you should be able to list all of your installed programs.

| improve this answer | |
  • 1
    Ahh so simple! Look at the preferences menu! This worked. Thanks! – Tenacious Qi Aug 2 '19 at 23:11
2

Your list may be truncated depending on the type of terminal you are using or for some other reason.

Instead of using: dpkg --list, use the following command instead:

dpkg -l | less

You will be able to scroll up and down the list using the arrow keys.

Use the q key to exit the list and quit.

Alternatively, you can use grep to search for a particular output like in this example:

dpkg -l | grep clementine

or

dpkg -l | grep clemen

If this doesn't work, please let me know and I will delete the answer. Thanks!


However, you mentioned:"How would I install something that starts with, say, the letter C like chrome, if the list only shows programs starting with the letter l thru z?". The answer is that you would use a different command to list available packages because dpkg -l and dpkg --list will only list installed packages.

To list available packages, you can use the apt-cache search command like in this example:

apt-cache search chrome

or

apt-cache search c | grep "^c"

Here, "^c" states to match results that begin with the letter c.

| improve this answer | |
  • @mchit, could you please see me in chat as I think your answer here is of value to anyone visiting the same question in the future as that's what most people will want to do... – Fabby Aug 3 '19 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.