0

I'm trying to bravely step forward into the "apt-world" and got these errors tonight testing upgrade from 16.04 to 19.04 on a clone (it's.. well... complicated...):

The following packages have unmet dependencies:
 indicator-bluetooth : Depends: unity-control-center but it is not going to be installed or
                                gnome-control-center but it is not going to be installed or
                                ubuntu-system-settings but it is not installable
 libdouble-conversion1v5 : Conflicts: libdouble-conversion1 but 3.1.0-2 is to be installed
                           Breaks: libdouble-conversion1 but 3.1.0-2 is to be installed
 libqt5dbus5 : Depends: qtbase-abi-5-5-1
 libqt5network5 : Depends: qtbase-abi-5-5-1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Does anyone know how to solve these errors or what additional information I can provide to help solve them?

The 16.04 to 19.04 upgrade is by script so I can install packages beforehand if that helps things out. I've recloned 16.04 and run the script five times to work out the other bugs and now I can almost see the light at the end of the tunnel.


Reply to comments

Currently only Unity Desktop is installed and converted by upgrade. After successful upgrade I plan to install Gnome Desktop and possibly Wayland.

I see even before upgrade there is a problem:

$ sudo dpkg -P libdouble-conversion1v5

dpkg: dependency problems prevent removal of libdouble-conversion1v5:amd64:
 libqt5qml5:amd64 depends on libdouble-conversion1v5 (>= 2.0.0).

dpkg: error processing package libdouble-conversion1v5:amd64 (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 libdouble-conversion1v5:amd64

The other item asked for:

$ apt list --installed | grep hw

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

hwdata/xenial-updates,xenial-updates,now 0.267-1ubuntu2 all [installed]
linux-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed]
linux-headers-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed]
linux-hwe-tools-4.15.0-54/xenial-updates,xenial-security,now 4.15.0-54.58~16.04.1 amd64 [installed,automatic]
linux-hwe-tools-4.15.0-55/xenial-updates,xenial-security,now 4.15.0-55.60~16.04.2 amd64 [installed,automatic]
linux-image-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed,automatic]
linux-signed-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed]
linux-signed-image-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed]
linux-tools-generic-hwe-16.04/xenial-updates,xenial-security,now 4.15.0.55.76 amd64 [installed,automatic]
lshw/xenial-updates,now 02.17-1.1ubuntu3.6 amd64 [installed]
xserver-xorg-core-hwe-16.04/xenial-updates,xenial-security,now 2:1.19.6-1ubuntu4.1~16.04.2 amd64 [installed]
xserver-xorg-hwe-16.04/xenial-updates,now 1:7.7+16ubuntu3~16.04.1 amd64 [installed]
xserver-xorg-input-all-hwe-16.04/xenial-updates,now 1:7.7+16ubuntu3~16.04.1 amd64 [installed]
xserver-xorg-input-evdev-hwe-16.04/xenial-updates,now 1:2.10.5-1ubuntu1~16.04.1 amd64 [installed]
xserver-xorg-input-synaptics-hwe-16.04/xenial-updates,now 1.9.0-1ubuntu1~16.04.1 amd64 [installed]
xserver-xorg-input-wacom-hwe-16.04/xenial-updates,now 1:0.34.0-0ubuntu2~16.04.1 amd64 [installed]
xserver-xorg-legacy-hwe-16.04/xenial-updates,xenial-security,now 2:1.19.6-1ubuntu4.1~16.04.2 amd64 [installed,automatic]
xserver-xorg-video-all-hwe-16.04/xenial-updates,now 1:7.7+16ubuntu3~16.04.1 amd64 [installed]
xserver-xorg-video-amdgpu-hwe-16.04/xenial-updates,now 18.0.1-1~16.04.1 amd64 [installed]
xserver-xorg-video-ati-hwe-16.04/xenial-updates,now 1:18.0.1-1~16.04.1 amd64 [installed]
xserver-xorg-video-fbdev-hwe-16.04/xenial-updates,now 1:0.4.4-1build6~16.04.1 amd64 [installed]
xserver-xorg-video-intel-hwe-16.04/xenial-updates,now 2:2.99.917+git20171229-1~16.04.1 amd64 [installed]
xserver-xorg-video-nouveau-hwe-16.04/xenial-updates,now 1:1.0.15-2~16.04.1 amd64 [installed]
xserver-xorg-video-qxl-hwe-16.04/xenial-updates,now 0.1.5-2build1~16.04.1 amd64 [installed]
xserver-xorg-video-radeon-hwe-16.04/xenial-updates,now 1:18.0.1-1~16.04.1 amd64 [installed]
xserver-xorg-video-vesa-hwe-16.04/xenial-updates,now 1:2.3.4-1build3~16.04.1 amd64 [installed]
xserver-xorg-video-vmware-hwe-16.04/xenial-updates,now 1:13.2.1-1build1~16.04.1 amd64 [installed]

The next step

I might be suffering from packages being held back:

Because all three packages exist in 16.04 they just aren't being upgraded to 19.04:

$ apt list unity-control-center
Listing... Done
unity-control-center/xenial-updates,now 15.04.0+16.04.20171130-0ubuntu1 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it

$ apt list libqt5core5a
Listing... Done
libqt5core5a/xenial-updates,xenial-security,now 5.5.1+dfsg-16ubuntu7.6 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it

$ apt list libdouble-conversion1v5
Listing... Done
libdouble-conversion1v5/xenial,now 2.0.1-3ubuntu2 amd64 [installed]

The answers in the link have many suggestions, the first one I'll try after work is:

sudo apt-get --with-new-pkgs upgrade
2
  • apt list --installed | grep hw and sudo dpkg -P libdouble-conversion1v5 please. Preferred desktop Unity or gnome-shell?
    – nobody
    Jul 31 '19 at 6:47
  • @nobody Question updated. Thanks, Jul 31 '19 at 10:36
1

I'll suggest to try deeper approach with one of the commands below:

  • try to get new dependencies

    sudo apt-get dist-upgrade
    
  • try Aptitude's safe-upgrade

    sudo aptitude safe-upgrade
    
  • try Aptitude's dist-upgrade

    sudo aptitude safe-upgrade
    
  • try Aptitude TUI to see broken packages

    sudo aptitude
    

If all these commands fail - then start over with removing obsolete packages with one of the methods:

  • with apt-get

    sudo apt-get autoremove
    
  • with Aptitude's TUI

    sudo aptitude
    

    and then navigate to Obsolete and Locally Created Packages and carefully remove packages from this section while controlling broken packages.

Notes:

  1. on clean Ubuntu 19.04 VM I can't install libdouble-conversion1v5 package as it came from 16.04 LTS.
  2. I have successfully ran upgrade of Ubuntu MATE 16.04 LTS to 19.04 with commands:

    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo apt-get install libdouble-conversion1v5
    sudo apt-get clean
    sudo sed -i 's/xenial/disco/' /etc/apt/sources.list
    sudo apt-get update
    sudo apt-get dist-upgrade
    

    but for upgrade of default Ubuntu 16.04 LTS (with Unity) → 19.04 I was forced to use sudo apt-get dist-upgrade -f several times until success and used sudo dpkg -i --force-all /var/cache/apt/archives/grilo-plugins*.deb (for only this package).

  3. Also I have successfully ran upgrade of Ubuntu MATE (and Unity) 16.04 LTS → 18.04 LTS → 19.04 with commands:

    sudo apt-get update # on 16.04 LTS
    sudo apt-get dist-upgrade
    sudo apt-get install libdouble-conversion1v5
    sudo apt-get clean
    sudo do-release-upgrade # with reboot into 18.04 LTS
    sudo sed -i 's/Prompt=never/Prompt=normal/' /etc/update-manager/release-upgrades
    sudo apt-get clean
    sudo do-release-upgrade # to 19.04
    

So it seems that we need to review your upgrade script :)

7
  • sudo apt-get dist-upgrade was a complete disaster the first few times to 19.04 and 18.04 because many packages were removed. I will do some homework on libdouble-conversion1v5 to see if I even need it in 16.04. Jul 31 '19 at 10:45
  • According to this: ubuntuupdates.org/package/core/bionic/universe/proposed/… libqt5qml5 which uses libdoubl-conversion1v5 on 2018-09-06 11:06:44 UTC was Moved to bionic:universe:updates. Jul 31 '19 at 10:55
  • I'll recommend to use more official site as LaunchPad, it says that in 18.04 LTS binary packages are named without v5. Currently I have started Ubuntu MATE 16.04 LTS VM, installed libdouble-conversion1v5 library on it and I'm running do-release-upgrade to 18.04 LTS. I'm using squid-deb-proxy, so the network traffic is not the problem for me :)
    – N0rbert
    Jul 31 '19 at 10:59
  • How do I tell Ubuntu to use Launch Pad instead of it's default server for this app'? Jul 31 '19 at 11:02
  • 1
    Accepting your answer and moving on as 16.04 to 19.04 is now successful. FTR to fix the above errors a simple sudo apt purge package_name did the trick. There were other complications with held back packages and apt-daily.service running on boot but they were all solved with existing Q&A here in Ask Ubuntu. Aug 4 '19 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.