0

Using vsftpd, all I want to do is share a directory I have with some friends and I am stuck. I am a newbie, so heads up. My ufw has the correct ports allowed, same as my router. I can SSH in so that tells me those are correct. Here are my config file (vsftpd.conf):

listen=YES
anonymous_enable=NO
local_enable=YES
local_umask=022
use_localtime=YES
listen_port=13000
ftpd_banner=So you want to steal movies.
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/private/vsftpd.pem
rsa_private_key_file=/etc/ssl/private/vsftpd.pem
ssl_enable=YES
pasv_min_port=13000
pasv_max_port=13100
userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
userlist_deny=NO
  • With this kind of problems you can always start trying with ping: if IP (ICMP) package reach the host. Then you can try if you can reach at TCP level: nc hostip port. Maybe you can ssh (22) but not ftp (21 by default), they are two different things. You can also try ftp (command) verbose output. To just share a folder you can use python -m SimpleHTTPServer or php -S 0.0.0.0:8080. – Pablo Bianchi Jul 30 at 21:01
  • Ok after doing your idea and another I found, I found that UFW was messing with my again. So I disabled ufw and I can now see it, but when I try to enter my credentials, it wont authenticate. I went in and changed my ftp user password using passwd, but no luck. – Shane Greenfield Jul 31 at 17:01
  • Now you have other problem. Please edit your question and title reflecting the changes. Is recommended to enable ufw and set it up with the correct necessary rules. Please use ftp verbose mode and add the output to your post. – Pablo Bianchi Jul 31 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.