1

I'm having an issue with the default screen sharing in Ubuntu 18.04.

I'm running Ubuntu Server 18.04 LTS in a VM and have ubuntu-desktop installed. I've enabled screen sharing in the settings menu and am attempting to connect to it through a VNC viewer on a Windows 10 machine.

I can connect to the VM and control the desktop, but I'm unable to view anything. All I get is a black screen. I've tried both tightVNC and VNCConnect viewers and both have the same issue. I've verified I'm running gdm3 and xorg server. I've also made sure ufw is disabled so no ports are being blocked. I'm attempting to connect to it over a local network and am able to access the server through other services such as apache, telnet, etc.

Has anyone run into this before? I've been all over Google and can't seem to find a solution that works.

Thanks.

1

Alright. I found the culprit. In case anyone is googling this later, if you're using Virtualbox as your VM manager, disable 3D acceleration. As soon as I did that, VNC worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.