6

I know this question has been asked here before, but the answers haven't helped me. I have a Lenovo Ideapad on which I've installed via UNetbootin 18.04. Everything else with the install went smoothly, but like others my wifi is not working. In particular, I've gotten the no wi-fi adapter found message.

Many of the fixes relied on gaining access to the internet via an ethernet connection, but my machine doesn't have a connection for that.

I haven't used Ubuntu in several years so my Linux foo is very rusty. I'm essentially a newbie.

03:00.0 Network controller [0280]:  Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
          Subsystem: Lenovo RTL8821CE 802.11ac PCIe Wireless Network Adapter [17aa:co24]

Let me emphasize newbie again. I don't know how else to post this. Here's the feedback now that I attempt to run make after updating and upgrading again:

/bin/sh: 1: cc: not found
(standard_in) 1: syntax error
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.18.0-15-generic/build M=/home/john/Downloads/rtl8821ce  modules
make[1]: Entering directory '/usr/src/linux-headers-4.18.0-15-generic'
arch/x86/Makefile:155: CONFIG_X86_X32 enabled but no binutils support
./scripts/gcc-version.sh: line 26: gcc: command not found
./scripts/gcc-version.sh: line 27: gcc: command not found
Makefile:970: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
make[1]: gcc: Command not found
make[1]: gcc: Command not found
make[1]: gcc: Command not found
make[1]: gcc: Command not found
/bin/sh: 1: gcc: not found
(standard_in) 1: syntax error
/home/john/Downloads/rtl8821ce/Makefile:2157: home/john/Downloads/rtl8821ce/hal/phydm/phydm.mk: No such file or directory
/home/john/Downloads/rtl8821ce/Makefile:2166: home/john/Downloads/rtl8821ce/rtl8821c.mk: No such file or directory
make[2]: *** No rule to make target 'home/john/Downloads/rtl8821ce/rtl8821c.mk'.  Stop.
Makefile:1534: recipe for target '_module_/home/john/Downloads/rtl8821ce' failed
make[1]: *** [_module_/home/john/Downloads/rtl8821ce] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.18.0-15-generic'
Makefile:2237: recipe for target 'modules' failed
make: *** [modules] Error 2
john@john-Lenovo-ideapad-130S-11IGM:~/Downloads/rtl8821ce$ sudo make install
/bin/sh: 1: cc: not found
(standard_in) 1: syntax error
install -p -m 644 8821ce.ko  /lib/modules/4.18.0-15-generic/kernel/drivers/net/wireless/
install: cannot stat '8821ce.ko': No such file or directory
Makefile:2243: recipe for target 'install' failed
make: *** [install] Error 1

Ran the commands and got these errors:

E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
john@john-Lenovo-ideapad-130S-11IGM:~$ sudo apt-get install libelf-dev
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
11
  • 1
    Let's start by identifying your exact wireless device. Please open a terminal Ctrl+Alt+t and run the command: lspci -nnk | grep 0280 -A3 Next, edit your question to show the result. Welcome to Ask Ubuntu.
    – chili555
    Jul 30 '19 at 21:23
  • Thank you. See above. Also, since I posted this, I re-installed 18.04 this time I ticked the box choosing 3rd party and propietary software, which didn't fix the problem. Thank you!
    – user81112
    Jul 30 '19 at 22:48
  • Here is the method to install the driver with a temporary internet connection by, for instance, tethering from your phone. askubuntu.com/questions/990378/… If this is an impossibility, I will write a lengthy answer as to the procedure without an internet connection. Do you still have the USB or DVD from which you installed Ubuntu? Many of the prerequisites are on it.
    – chili555
    Jul 30 '19 at 23:24
  • I do still have the usb drive I used. I'll try to tether to my phone first
    – user81112
    Jul 30 '19 at 23:27
  • Rats. Tethering is not working. I'm still not connected.
    – user81112
    Jul 30 '19 at 23:35
14

Please open a terminal and do:

sudo apt-get update && sudo apt-get install build-essential git dkms
git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
chmod +x dkms-install.sh
chmod +x dkms-remove.sh
sudo ./dkms-install.sh   
sudo modprobe 8821ce

Your wireless should now be working.

Revision 31 July, 2019 9:40 am EDT

21
  • Working through it. Thank you!
    – user81112
    Jul 31 '19 at 0:11
  • Everything went great until I typed 'make' after editing the file. I got the message Command 'make' not found, but can be installed with: sudo apt install make sudo apt install make-guile I tried each of those commands and was told that those could not be located.
    – user81112
    Jul 31 '19 at 1:11
  • Just realized I'm no longer tethered.
    – user81112
    Jul 31 '19 at 1:13
  • connected again, but same problem.
    – user81112
    Jul 31 '19 at 1:16
  • 1
    Its really really helpful Jan 17 '20 at 7:31
0

Pre-requisites:

  1. The command 'lspci' shows the wireless card as RTL8821CE

  2. You have a successful internet connection through USB thetering

I had a similar problem with my newly purchased Lenovo-V145-15AST, as Ubuntu did not find an active WiFi adapter after installing Ubuntu 18.04.3 LTS.

As the wireless card was not found during Ubuntu installation, updates and upgrades were not performed during the installation. It seems that this prevented the successful installation of the driver for the RTL8821CE wireless card when I followed the advice of various posts on this issue.

What worked for me, provided that the command lspci does indeed list the wireless card, and that one has managed to theter via smartphone-USB, was the following:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install git

as suggested in the second answer to this question: https://stackoverflow.com/questions/56901922/error-showing-in-the-installation-of-git-in-ubuntu-18-04-2lts

Then followed this to the letter: https://github.com/tomaspinho/rtl8821ce

After rebooting, the wireless card was up and connecting to my WiFi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.