0

So I've been trying to solve this issue for about 10 non-straight hours, without success. I have installed Xubuntu 19.04 on an ASUS laptop from scracth, and I would like to have the nvidia drivers pumping. It's far from the first time I have done this, on multiple PCs but this one is proving to be quite hard. Almost everytime the driver is installed, I get a black screen upon reboot.

I have already tried several common methods such as:

  • Inserting "nouveau.modeset=0" and "nomodeset" in kernel params
  • Trying out various driver versions (340, 396, 415), either from "Additional Drivers" or through the shell and the repositories (purging old files between each version ofc)
  • Disable secure boot in bios options
  • using nvidia-xconfig to generate a xorg.conf file

None of these steps worked completely, most of them continued the black screen. And honestly I probably tried more things than I can remember now.

So, after much poking around and messing the system I decided yet to reinstall Xubuntu, without proprietary drivers, and give a try to the nvidia 418 driver aftewards. This was the last step I did, and now with the 418 drivers installed the system effectively boots, I can login to the GUI but the resolution can't go past 1024x800. Also, if I go to Nvidia X Server Settings, it only shows the "PRIME Profiles" tab. So I'm guessing the driver isn't still being used properly.

Any help is appreciated as I'm running out of know options here. I'll also post any output requested asap

System Specs: ASUS X555LD Laptop, Intel core i3, 4GB RAM; Graphics: Intel Hashwell Integrated graphics + NVidia GeForce 820M ; OS: Xubuntu 19.04

  • That you must disable Secure Boot (or manually sign the drivers) is a given. So, start there and keep it disabled. – GabrielaGarcia Jul 30 at 18:29
  • @GabrielaGarcia I know, I actually tried the two ways, with SB disabled , and with it enabled and creating and enrolling the MOK keys. In the whole process those bits were always successfull, so I'm not sure If it's related to it but ty anyways :) – NGSBNC Jul 30 at 19:02
  • Try: sudo ubuntu-drivers autoinstall – Marc Jul 31 at 1:03
  • possibly this one askubuntu.com/questions/1162195/… – pierrely Jul 31 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.