0

Since yesterday I try to install Ubuntu 18.04.2 LTS on my Laptop Acer Swift 1 where I had Windows 10 previously. Initially I had some problems with the installation start, but I disabled "secure boot" and it worked. however, now the Ubuntu starts installing and everything goes smooth, but then the installation suddenly stops the progress and I get "Installing the grub2 package". This can last hours without any progress.

I tried to open the Terminal in the background and typed the commands:

sudo fdisk -l
sudo mount /dev/sdxY /mnt  (where x is altter and Y a number you have found in the previous step)
sudo grub-install --root-directory=/mnt /dev/sdx 
sudo update-grub

Well, this did not work. An error message occurred: "grub-install error: will not proceed with blocklists".

I have swap area, ext4 space and EFI space. Separating my free space into these categories did not help too. How can I finally install the Ubuntu?

Now if I start my laptop without the USB inside, I get a black screen with the title "GNU GRUB version 2.02" and I have to enter some commands. What should be done? I get almost to the final stage, but the grub2 packages can not be installed.

  • The problem is that I dont have the Windows anymore. When I start the laptop now, I get a black screen with the title "GNU GRUB version 2.02" and I have to enter some commands. Should I open the terminal from the BIOS? – Nick Jul 30 at 15:14
  • oh, then that's fine, do this (you have to use option "try ubuntu" when the usb key boots to be able to open a terminal): askubuntu.com/a/182863/307184 you probably won't even need to install ubuntu after that. it should have both windows and ubuntu booting correctly after that. – tatsu Jul 30 at 15:16
  • Nice I followed the instructions there and I clicked on recommended boot repair, but now I am waiting for about 15 minutes and semms the boot repair has also issues. It says: "Reinstall GRUB. This may require several minutes" and it is loading. I am a patient person and will wait more, but I think something is wrong there :D – Nick Jul 30 at 15:45
  • yeah it's really fast normally, takes about 1-2 minutes for me. something's wrong. maybe you'll have to use a windows install usb/CD to repair boot. – tatsu Jul 30 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.