2

I have a new virtual environment in Ubuntu (terminal only) and I am trying to open a new terminal window (so I would have two views) however when I enter gnome-terminal to open a new terminal window I get the a command not found error.

enter image description here

Could someone let me know what I need to do to open more than one terminal window please?

Tried adding tasksel and got back: enter image description here

I also tried: sudo apt update; sudo apt install tasksel enter image description here

Thanks

  • gnome-terminal is the terminal if you have GNOME desktop loaded/running. You mention Ubuntu (terminal only) which implies to me you don't have GUI/GNOME there, so why would gnome-terminal be there? I'm not quite sure what you're after; (1) ctrl+alt+f4 to switch to term 4? or (2) bash to open a new shell? .. or (3) are expecting/wanting gui features to work despite not running a gui? – guiverc Jul 30 '19 at 7:53
  • Thanks @guiverc - I would just like to be able to view my Ubantu environment from more than one terminal view (so I have 2 or more terminal screens for me to view different parts of the environment I'm working on). I've tried Ctrl-Alt -T without success as well – Stacey Jul 30 '19 at 8:08
  • 1
    Ctrl+Alt+T is a another gui/X shortcut so shouldn't work if you are using server with text terminal only (no X or gui operational). Ctrl+alt+Fn key will jump to another text terminal (you can have more or less than the default, but only one displays at a time), but to have more than one display on a screen requires X (or wayland, etc) to be enabled & running (see askubuntu.com/questions/7881/what-is-the-x-server or en.wikipedia.org/wiki/X_Window_System) – guiverc Jul 30 '19 at 8:14
  • 1
    Virtual consoles anyone? We still have those, right? – hobbs Jul 30 '19 at 17:40
6

Because your setup is "terminal only", you currently cannot run apps that run a graphical user interface or GUI. However, you can use something like tmux which will allow you to "tile" your terminal.

Run the following commands to install tmux:

sudo apt update
sudo apt install tmux

Then, to run tmux, just type the following command:

tmux

Now, to run in "split window" mode, press Ctrl and b at the same time, release both, and then press the % key.

The the % key is actually Shift + 5 of course.

To navigate to the left and right terminal, press Ctrl and b at the same time, release both, and then press the left or the right arrow key.

Click here to view "a quick and easy guide to tmux".

Click here to view "a tmux crash course".


Alternatively, if you want to install a complete desktop setup with application-windows and graphical applications, you can run the following command:

sudo tasksel

Then, you can select your desired desktop environment. Choosing the "Ubuntu desktop" will install Gnome applications such as Gnome Shell and gnome-terminal. Do not select any of the "live cd" options.

You can use your arrow keys to scroll down to "Ubuntu desktop" or you can choose any one of the other Ubuntu flavours (like Xubuntu desktop, Ubuntu Mate desktop, etc . . .). Each of these desktop environments uses a different set of applications. For example, Xubuntu uses xfce4-terminal instead of gnome-terminal.

Finally, use the space bar to select or deselect a desktop and then use the tab key to select "OK" and then press Enter to install.

| improve this answer | |
  • If the system complains that tasksel is not installed, you can install by running the following command: sudo apt update; sudo apt install tasksel – mchid Jul 30 '19 at 9:10
  • Thanks @mchid I tried sudo taskel and sudo apt update; sudo apt install tasksel without success (please see edit to the question for output from running the commands. Any idea what I should try? Thx – Stacey Jul 30 '19 at 10:06
  • @Stacey If you are sure that your virtualbox is set up properly to be connected to the internet, you can do a temporary DNS fix by running the following command: echo nameserver 8.8.8.8 | sudo tee /etc/resolv.conf Then, try to update and install again. However, you will need to set this again after you reboot. – mchid Jul 31 '19 at 3:23
5

As already mentioned by other, apparently you have a server (no GUI) installation, and therefor only one "console" available.

What you can do though, is using ssh to connect to your Ubuntu virtual server:

ssh user@ip-address-of-server

or use the putty application to do the same. Putty also works from Windows. This will give you as many terminal sessions as you like.

| improve this answer | |
  • 2
    Within nowadays Windows 10 you can use ssh directly from cmd.exe (and power-shell), also WSL is available. – pa4080 Jul 30 '19 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.