0

Recently installed Xubuntu 18.04 LTS(bionic beaver) as dual boot alongside Windows 10 on my Dell laptop. Neither hibernation nor suspend is working. When I close the lid of my computer and open it again I get a black screen. Machine seems to be running but I get no response. Only option is to hit the shutdown button to force shutdown.

Since I did not create a swap partition on installation, I used a live cd to resize my Ubuntu partition and create a swap partition. I also hit the swapon option in Gparted.

Rebooted the computer back into Xubntu but still no go... same problem with suspend and hibernate.

I've looked at this answer to edit /etc/fstab but I'm not sure if that's the right thing to do.

here's how my/etc/stab file looks like:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation 
UUID=7adff708-01f9-4897-92e9-647aae470f4f /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=3E4C-F177  /boot/efi       vfat    umask=0077      0       1 /swapfile            none            swap    sw              0       0

laptop specs:

  • bus Motherboard
  • memory 7874MiB
  • processor Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
  • bridge Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
  • display HD Graphics 620
  • generic Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem
  • bus Sunrise Point-LP USB 3.0 xHCI Controller
  • generic Sunrise Point-LP Thermal subsystem
  • 1
    Hibernate by definition means requires the power to be turned off, so any memory contents will be lost - and swap is where those contents go. For hibernate to work you must have sufficient swap to save whatever is already in swap + the full contents of your ram. You didn't tell us what release of Xubuntu (thus we don't know if you can use swap files, or swap only). Rather than forcing shutdown (which will force a fsck) do sysrq keys allow shutdown? Also please don't include pictures of text (harder to read & we can't copy/paste from them). – guiverc Jul 30 at 8:53
  • added xubuntu version. I tried sysrq keys for restart and it worked. @guiverc – J.Doe Jul 30 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.