0

I'm trying to recover on an external hard disk two partitions that correspond to the "/" and "home" divisions of Lubuntu 19.04.

I was using my main system, Lubuntu 19.04, (which is on an external HDD) on a cousin's laptop. I noticed that for this session there were annoying freezes for no apparent reason -- I was just using Firefox --, so I opened htop (with a lot of effort) and noticed a very high consumption of RAM and SWAP.

After closing a few tabs before doing a reboot... Boom! -> I skipped the black boot screen containing the boot lines ([ OK ] Blablablabla...). The PC is frozen at the moment. It does not react to anything.

It didn't occur to me much more than to disconnect the E-HDD, take the battery out of the laptop (it has a problem with the button), connect the E-HDD in another port to change position (it was in my bed), put the battery back in and try to start again. All in that same order.

Surprise mine that when starting the PC shows me the screen grubrescue>_. It occurred to me quickly to relapse in the Lubuntu 18.04 of the laptop and to revise. After a brief review and confusion I discovered in GParted that the partitions /dev/sdb3 and /dev/sdb4 are shown as "unknow", but with the "Name" with "Linux filesystem" in each one.

I tried mke2fs, e2fsck, fsck.ext4, fsck, with "-p" and "-b block_number", but the error always ends up being the same:

fsck.ext4: Group descriptors look bad... trying backup blocks...
fsck.ext4: Bad magic number in super-block while trying to open /dev/sdb3

The superblock could not be read or does not describe a correct ext4 filesystem. If the device is valid and it really contains an ext4 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: [...]

It should be noted that I use GPT, not MBR. Well... So I tried all the blocks and all those tools, but nothing.

I'm researching how to use testdisk. I installed it and opened it and it recognized me a disk label that I had put before for the home page and other partitions, but I don't know exactly what "write filesystem structure" means and I'm afraid to break something.

At the moment I only have GParted running an "Attemp to Data Recover" while I investigate. At this exact moment I can't show the "minimal, reproducible example" for this very reason.

I'm pretty sure my information is still there... But I need to work with it. I don't have copies of the files I need. Every minute that passes is a little hopeless.

Any idea?

--- EDIT 01 ---

TestDisk doesn't work for me. It doesn't list directory files. Cannot find SuperBloks. It does not detect if it is EXT4 or what. Just take these two partitions as strange. And GParted never found anything so I closed it.

Actual GParted state Ignore "unallocated" fills.

Everything is telling me that I should do a data extraction with recovery tools. I hope the next few minutes of searching will help me not to.

  • 1
    Have you checked the health of your drive (ie. read it's SMART data?) If I have a disk problem, it's the first thing I check, before i think of fsck or anything that changes data). Lubuntu 18.10 up uses KDE Partition Manager to read/view this information which I'd run from a 'live' system so it's ready only the data from the drive electronics (not touching platters in case it's failing or had bad error), though you could use smartctl from command line, or gnome-disks (if you have Ubuntu install media around etc). To me fsck & fixing/recovery is second step. (ie. was there a reason..) – guiverc Jul 30 at 2:02
  • are you just trying to retrieve the data, or are you trying to diagnose and repair the problems with your installed system? If you just need to get data, you can use a live USB, that way you won't have to deal with whatever is going on with your RAM. – Nmath Jul 30 at 2:35
  • @Nmath, I'm trying to restore the integrity of my partitions. – DATALOT Jul 30 at 2:44
  • @guiverc You're right about what you're saying. But in the same way it must be very strange that the only two partitions I was running at the time are damaged. Apart from the fact that it's not just a damaged partition, I had already run badblocks before I started using that HDD without errors. That's about three months ago. – DATALOT Jul 30 at 3:01
  • 1
    There are many many conditions that can impact only portions of a disk, but other parts of the disk are still functional/normal; your two partitions could be where a problem is. I'm not talking about badblocks (which is again not first step), but reading the health of the drive from the drive electronics itself; have the number of errors started increasing recently, has drive health started dropping over it's health last month etc (ie. this even is an early warning sign of coming problems) – guiverc Jul 30 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.