1

19.04 ubuntu login suddenly stopped working today after small upgrade. I can login fine with Wayland (whatever that is) but doesn't solve my problem as I need X to run vmware player.

running sudo startx gives

xauth:  file /home/tim/.Xauthority does not exist

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-143-generic x86_64 Ubuntu
Current Operating System: Linux tim-XPS-15-9570 5.0.0-21-generic #22-Ubuntu SMP Tue Jul 2 13:27:33 UTC 2019 x86_64

Kernel command line:

BOOT_IMAGE=/boot/vmlinuz-5.0.0-21-generic root=UUID=91c0547f-e260-419d-b23c-fdbb6995cf59 ro quiet splash pcie_port_pm=off acpi_backlight=none acpi_osi=Linux "acpi_osi=Windows 2009" nouveau.noaccel=1 rd.driver.blacklist=nouveau nouveau.modeset=0 vt.handoff=1

no .xerrors nothing in syslog that looks like a crash I'm running on a notebook and same result with or without plugged in external monitors. I tried installing gnome stuff and can log in as gnome but not gnome on Xorg

running dell xps 15, single-boot Any more suggestions or should I just give up and try re-installing?

0

Ok, not a definitive answer to may own question - I gave up and reinstalled. However, while reinstalling, I reinstalled the touchpad-indicator utility at some point in the process. This disabled my wifi. Removing it re-enabled my wifi. I didn't investigate thoroughly but I suspect the login loop might have been caused by failure in touchpad-indicator which may have some compatibility issues with very latest updates to 19.04. But this is just a conjecture.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.