0

I installed Alice via Synaptic few days ago using Ubuntu Mate 16.04.06, but I can't find and run it thou... how to run it??

It's not on the Applications drop-down.

I ran it via terminal few days ago it says:

user@testbox:~$ alice
No config found, writing a few config to /home/user/.alice/config
Location: http://127.0.0.1:8080/

Today I ran it again:

user@testbox:~$ alice
Location: http://127.0.0.1:8080/
^C

that I gotta ^C it.

The ~/alice/config file says:

{
  'images' => 'show',
  'style' => 'default',
  'address' => '127.0.0.1',
  'debug' => 0,
  'monospace_nicks' => [
    'Shaniqua'
  ],
  'servers' => {},
  'static_prefix' => '/static/',
  'auth' => {},
  'avatars' => 'show',
  'alerts' => 'show',
  'message_store' => 'Memory',
  'port' => '8080',
  'timeformat' => '24',
  'highlights' => [],
  'order' => [],
  'ignore' => [],
  'quitmsg' => 'alice.'
}

WTH?? How do I supposed to figure it out ??? I gotta write something a config, or it's already written?

Why does it say 'writing the config' after just I try run Alice and location of my localhost ip address? How weird is that ?? wth man???

Isn't it supposed to be already ready after everything?? I used Ubuntu 10.10 it was pretty great.. Why are newer OS especially Ubuntu aren't any better nowadays, except maybe Lubuntu and XFCE.. Now new default Ubuntu looks like piece of shit cakey flakkey scrambled everything..

How do I supposed to figured it out already?

I am still a pretty newbie in Linux, pretty regular Windows User.

  • 2
    I suggest that you edit this to say what you expected when you ran alice and what happens when you visit http://127.0.0.1:8080/ in a web browser while alice is running (from the machine it's running on). You ran it twice and it seemed to work both times! The first time, there was no configuration file, so it generated one automatically. ...Or did you intend to install a different program called "Alice"? The program you installed has a web-based interface and no other GUI. One shouldn't expect an entry for it in a desktop menu. Right now, I think it's unclear what you're asking. – Eliah Kagan Jul 29 '19 at 15:12
  • 1
    Your title suggests you're looking for apt. Then you say you can't find alice. You also say you can't figure out how to run it. Then you run it. Then you describe problems with running alice. These are rather contradictory and confusing. I would suggest that you edit your question and make things more clear and focus specifically on the matter at hand. I would especially exclude the superfluous commentary, especially given the use of offensive language. – wxl Jul 29 '19 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.