4

I am trying to install Ubuntu 19.04 (or any other Linux distro) on a new HW consisting of Ryzen 3900X CPU, Gigabyte Auros Master X570 motherboard and AMD Radeon Vega 64 GPU. On installation startup from a bootable USB drive, it shows "Ubuntu" with 5-6 dots underneath representing installation progress. However, it is perpetually stuck in that mode. When I press ESC, it shows dozens of lines of failure messages.

I searched internet for a clue as to what is causing this and to fix it with no avail. Some suggest Gigabyte motherboard is not fully compatible with Linux. I have tried the same with Manjaro but again similar failures. I have tried changing IOMMU to "enabled" but did not work either.

Can anyone help? Although I have used Ubuntu, my technical knowledge is very limited in attempting to resolve the issue.

If other ditro will work, I am willing to use it. But Ubuntu is my preference.

5

Try Ubuntu 18.04.

19 doesn't work.. . For now.

I've read on phoronix that it has an issue that should be fixed in the near future. They don't know exactly if it's a kernel or motherboard problem but it will surely be fixed in a patch someday

Edit: my friend had same issue and successfully booted Ubuntu 18.04 on his 3700x build (Asus x570 hero motherboard).

"While Ubuntu 18.04 LTS and older Linux distributions boot Zen 2, to date I have not been able to successfully boot the likes of Ubuntu 19.04, Manjaro Linux, and Fedora Workstation 31. On all newer Linux distributions I've tried on two different systems built around the Ryzen 7 3700X and Ryzen 9 3900X, each time early in the boot process as soon as trying to start systemd services, all systemd services fail to start."

Source :

https://www.phoronix.com/scan.php?page=article&item=ryzen-3700x-3900x-linux&num=1

  • Hi Daniel, thank you for your reply. It worked a treat. Ubuntu 18.04 is installed and working fabulously. I was ready to give up on Ubuntu but now I am as happy as can be. A big relief knowing that I don't have to use Windows. Thank you so much. Cheers – Albert Chang Jul 30 at 2:40
2

I was able to get 19.04 to boot by first installing 18.04, then updating to 18.10, then to 19.04.

One interesting thing is that it's still running kernel 4.18.0-25-generic.

Update:

AMD released a new microde (think that's the right terminology) to motherboard manufactures. I have an X570i (itx), and if you look under the bios section here https://www.gigabyte.com/us/Motherboard/X570-I-AORUS-PRO-WIFI-rev-10/support#support-dl-driver you'll an update for 'Improve Destiny 2 gaming compatibility'. I believe this fixes the issue systemd was having on linux kernel 5 and above.

After I updated my bios, I did a clean install of Ubuntu server 19.04 with no issue.

  • Thank you for that. I have installed 18.04, upgraded it to 18.10 and then upgraded it to 19.04. It worked just as you suggested. Very happy. Cheers – Albert Chang Sep 29 at 6:21
  • FYI, as long as you update your bios, you don't need to go from 18.04 -> 19.04. Start with 19.04. The only reason updating works is because for some reason the linux kernel stays on v4, which isn't the greatest. You want to have the latest kernel. – pwaterz Sep 29 at 20:08
0

I have the Gigabyte X570 ULTRA board with AMD 3700x, and faced the same problem like Albert reported in his question. I checked the BIOS of my motherboard, it was version F3, published in Jun 2019. Thus I updated to newest version F6b (published by Gigabyte Sept 2019), and then the installation of Ubuntu 19.04 worked like a charm.

So just update your BIOS, in case you have the Gigabyte X570.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.