0

it used to be possible to access an FAT 32 Ubuntu (18.04) formatted flash drive in my Win 10 PC. For some time now, When I plug an Ubuntu formatted USB drive (tried 3 different ones) it is not recognized and the Bluetooth keyboard mouse freezes. Removing the flash drive situation becomes normal. Tried all the ports. The Flash drive and the Bluetooth one are in different ports, but it doesn't matter. I use Nautilus, no option offered.Tried also with Disks and Gparted.

Purchased a brand new Sandisk drive. Here's how it went: Just plug it to the PC - OK. Format in Ubuntu as above, First pug in not recognised by PC, remove and replug Kaspersky message external device should be scanned, scan was clean, drive is recognized. This is repetitive. Mouse and keyboard working normally.

Thanks, tried your CL. All I get is error "Device partition expected, not making filesystem on entire device '/dev/sdc' (use -I to override)" (drive is 16GB)

  • How are you formatting the flash drive? If you are using a command line utility, please copy and past the exact command in your question and format the command as code. If you are using a GUI app, edit your question and add details like the name of the app and which options you selected within the app. – user68186 Jul 28 at 22:44
  • You may find this question and its answer helpful. – user68186 Jul 28 at 23:37
0

The solution was: Use Gparted to erase the primary partition, re create it and then format. There's a hidden bug somewhere.

  • 1
    That might be the solution, but you haven't said what it was you did that caused the apparent problem in the first place. There's not much point in knowing the solution if we don't know what the problem is. – Ray Butterworth Aug 1 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.