1

Hi I'm having some issue regarding Ubuntu 16.04 and I'm unable to fix it after lot of trials. I am having dual boot of Ubuntu 16.04.6 with Windows 7.

Whenever I try to Restart the Ubuntu it gives a complete "Black Screen".

whenever I try to shutdown it freezes after "Reached Target Shutdown" and forcefully both the times I had to hard restart it by pressing power button.

Solutions tried up till now:

  • boot repair
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
  • In recovery mode trying for broken packages but its getting aborted

None of the Solutions worked. earlier it was having issue in booting up also but somehow it seems that it has recovered from it.

But restart and shutdown NO solution.

system config: Dual boot Windows and Ubuntu 16.04.6 LTS with 8GB RAM kernel version 4.4.0-154 and kernel version 4.4.0-157 Intel Bay Trail processor Inbuilt Intel Graphics(No Nvidia)

EDIT: sometimes I can boot perfectly while using the system also there is no freeze but every-time when I do restart or shutdown it freezes completely.

I did boot repair from system itself not from live CD and here are the results. enter link description here

for the command sudo fsck -f / in recovery mode the results are

fsck from util-linux 2.27.1
e2fsck 1.42.13
/dev/sda5 is mounted.
e2fsck: cannot continue, aborting.

when I ran recovery mode for old kernel 4.4.0-154 there was one failure

Failed to start Tell Plymouth To Write Out Runtime
  • When did it stop working? Had you made any significant changes to your system: new hardware, new software, kernel update, new drivers, new OS? If so, you may want to reverse these changes, or boot from an older kernel in recovery. Additionally, please edit your question to include detailed results of the failed boot-repair and explain what you mean "it's getting aborted". Instead of summarizing in your own words - the raw output of errors/failed attempts is much more helpful to diagnose your issue – Nmath Jul 28 at 16:24
  • earlier both the OS failed to boot it was having Black Screen of Death. after I gave it for repair he replaced some rusted IC and cleaned the motherboard. when I got back the laptop from repair shop Windows started working perfectly fine not even single glitch but ubuntu is freezing. In hope to solve this I did sudo apt-get update but not getting any solution. Did above mentioned workaround but still No success. – Tushar Jul 28 at 18:50
  • sudo apt update only updates the list of available software. If you follow that with sudo apt upgrade this is the prompt to update (upgrade) all available packages. The reason the detailed results of boot-repair were requested is because it provides valuable information about your system config and gives insights into successes and failures and how to fix problems. Please try boot repair again (from a live USB) and make sure to edit your post to include the results in your question. FYI W7 reaches end of life in 5 months. If you've got extensive problems, OS reinstalls may be warranted – Nmath Jul 28 at 20:23
  • @Nmath I have edited the post as per your guidelines. I have mentioned the boot repair link in post still I'll mention it here paste.ubuntu.com/p/vtKSKzn3F3 – Tushar Jul 29 at 4:38
  • " did boot repair from system itself not from live CD" you must perform boot-repair from within a live CD/USB as mentioned above. Utilize these instructions on how to repair GRUB. Even if this is successful, it sounds like you will still have an additional problem to deal since you mention having issues even when successfully booting. – Nmath Jul 29 at 4:59
1

To answer my own question. After trying all the solutions from the internet which are mentioned in the question itself and even after trying different OS(Ubuntu 18.04, Linux Mint) finally I figured it out what was causing the issue. There is one entry in BIOS known as "USB 3.0 Configuration in Pre-OS" which was Enabled by default. Once the entry was Disabled shutdown, restart everything started working fine. Also to mention now I have completely moved on from windows and now running only linux OS. For some people turning Off "USB 3.0 legacy" mode might also work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.