1

My 1 Tb external HDD is not seen by my laptop but woks fine on my desktop.

Laptop is running Ubuntu 18.04.2

Desktop is running Xubuntu 18.04.2

HDD also works on Windows and Mac machines, so the issue is with the laptop, not the HDD.

On the Laptop:

lsusb shows the HDD is listed as a device.

fdisk -l does not list the HDD

gparted does not see the HDD either.

USB memory sticks work and automount as expected.

My problem seems a little like this guys problem, but I'm not sure if I understand his solution, or if it would work for me: https://www.linuxquestions.org/questions/linux-hardware-18/external-usb-hard-drive-not-detected-bu-usb_storage-4175575404/

How can I successfully mount my external HDD on my laptop?

  • Did you try all the USB ports on your laptop with the external drive? – WinEunuuchs2Unix Jul 27 '19 at 23:54
  • Yes i tried them all. – Gideion Jul 28 '19 at 1:37
0

The laptop USB ports probably don't supply enough power for the external USB drive, especially if it's >1TB.

Another possibility is that if the external drive is USB 3.x, and the laptop only has USB 2.x ports, that the external drive's USB 2.x backwards compatibility isn't working correctly.

Either:

  • use a USB 3.x port if the external drive is USB 3.x

  • check if the BIOS supports "legacy" mode for USB

  • plug an AC adapter into the external drive case, if available

  • use a POWERED USB hub between the laptop and the external drive

  • use a special USB "Y" adapter such that the external drive connects to two USB ports on the laptop... one for signal and power, and the second for additional power

Update #1:

Current BIOS is version F.48. Version F.49, released May 19, 2019, is available here.

| improve this answer | |
  • The laptop is an HP Spectre x360 13-AC023DX. I have tried the drive via both the USB 3.1 Type-A Gen 1 port as well as by the USB 3.1 Type-C Gen 2 port, while the laptop was connected to power. Neither worked. – Gideion Jul 28 '19 at 0:34
  • I also tried the USB 3.1 Type-C Gen 2 port with the drive and laptop power connected to a USB-C hub and then into the laptop, again nothing. – Gideion Jul 28 '19 at 0:39
  • @Gideion check your BIOS version with sudo dmidecode -s bios-version and it should be F.49 Rev.A released May 19, 2019. If not, go to support.hp.com/us-en/drivers/selfservice/… – heynnema Jul 28 '19 at 0:40
  • Every time the drives power light comes on, and I can hear the dive. It shows up under USB devices, but nowhere else. – Gideion Jul 28 '19 at 0:41
  • currently F.48. I'll try updating. – Gideion Jul 28 '19 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.