1

I have installed Ubuntu 19.04 on my Huawei Matebook 13 and got everything working except automatic switching between laptop speakers and headphones. When they are plugged in, audio is still coming out of the speakers and they are not shown in settings. In fact the only partial solution to my problem was to install pavucontrol and manually switch the output to headphones. In pavucontrol, the headphones are shown as Unplugged, which means that the laptop does not recognize the headphones as being plugged in.

pavucontrol
pavucontrol

How can I fix my headphones not being recognized?

2

Try:

"sudo echo "options snd_hda_intel model=dell-headset-multi" >> /etc/modprobe.d/sound.conf"

Reboot after.

2
  • 1
    I discovered this exact solution on GitHub, but it was the day after asking this question and by then I had already forgotten about it. Nonetheless, thank you for answering. github.com/nekr0z/linux-on-huawei-matebook-13-2019 – Jakob Kenda Aug 1 '19 at 22:39
  • I would like to know why we used dell-headset-multi even though it is a huawei notebook? – Hoshani Feb 19 '20 at 13:58
0

A slight variation on kopro314's answer. In Kubuntu 19.10 I had to edit /etc/modprobe.d/alsa-base.conf.

So the command you would execute is:

echo "options snd_hda_intel model=dell-headset-multi" | sudo tee -a /etc/modprobe.d/alsa-base.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.