1

I am using Xubuntu 18.04, XFCE 4.12.2 on a laptop with an external monitor. I only use the external and disable the built-in laptop monitor. When I suspend a session and resume, the built-in monitor is turned on, then off after I logged in, but the backlit light (of the built-in monitor) is still there. If I want it to be totally off, I have to go to Display setting, turn it on and off again.

I don't know if this is a bug or am I missing something?

Thank you in advance!

0

This is a common bug when using a laptop with an external display. Without knowing your exact laptop model, I don't think I can provide an exact solution, but below is what works for me on one of my testing laptops that has the same issue.

You should be able to manually set the backlight by manipulating the device files in /sys/class/backlight, and then create a desktop/keyboard shortcut for this so that it's easy to do when you unlock your machine.

Run ls /sys/class/backlight to see which backlit displays are available. If you only have one, this will probably output something like acpi_video0.

To set the backlight, run echo 0 > /sys/class/backlight/acpi_video0/brightness. This should take effect immediately.

In XFCE, you can right click your desktop to create a launcher/shortcut, or use the settings menu to create a keyboard shortcut.

You'll need root/sudo access to edit the file, so you can set your launcher to xfce4-terminal -e "echo 0 | sudo tee /sys/class/backlight/acpi_video0/brightness" to make sure that you are prompted for your sudo password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.