1

I'm completely new to Linux OS environment & wanted to experiment a bit.

After installing Ubuntu 18.04.2 TLS (& productivity software), I tried back-up my system w/ the Backup software provided

I got my first error: Failed to execute child process "duplicity" (No such file or directory).

I read on this forum that I had to install Duplicity to get it to work.

So, I ran this command:

sudo apt install duplicity

and got another error:

Reading package lists... Done
Building dependency tree
Reading state information... Done

E: Unable to locate package deja-dup-backend-gvfs

Help would be appreciated before I sink down an error rabbit hole

Was also told to run these:

apt-cache policy | egrep -vi translat

Package files:

100 /var/lib/dpkg/status

release a=now

Package files:

apt-cache policy duplicity

duplicity:

Installed: (none)

Candidate: (none)

Version table:

Thanks Much!

  • Please edit your question and show apt-cache policy | egrep -vi translat and apt-cache policy duplicity – nobody Jul 26 at 15:28
  • Done. Thanks for the help. – Never3Putt Jul 26 at 22:59
  • 1
    Something odd is going on. Is your system a new install, not an upgrade? Because deja-dup-backend-gvfs does not appear to be an 18.04 package (it is in xenial). It is also concerning that there is no candidate for duplicity. I fear something is deeply wrong with your system's apt setup. – Organic Marble Jul 27 at 0:57
  • I agree with @OrganicMarble 's assessment. Please post the output of sudo apt update && sudo apt dist-upgrade but be prepared to reinstall (Remember how many times you've reinstalled Windows before you got it right? You're up the same learning curve, but with help now...) ;-) – Fabby Jul 27 at 8:04
1

Where is your sources.list gone?

create the file/etc/apt/sources.list with following content.

deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

Then update package information from all configured sources with

sudo apt update

sudo apt install duplicity
  • ** (gedit:29979): WARNING **: 20:24:55.295: Set document metadata failed: Setting attribute metadata::gedit-spell-language not supported – Never3Putt Jul 30 at 0:26
  • Seemed to resolve the issue, but I got the above error when editing the the sources.list file with gedit – Never3Putt Jul 30 at 0:36
  • Only, warnings if program works, nothing to do. – nobody Jul 30 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.