2

It is a wifi connection with no proxy... I supposing that I removed all proxy configs, and Firefox is working fine. But any terminal command line not works:

  • curl --verbose http://w3c.org say (5) Could not resolve proxy: http.
  • wget http://w3c.org say failed: Name or service not known. wget: unable to resolve host address ‘http’.

About wget error, I tested this change resolv.conf suggestion but no effect.


NOTES:

  • changing URL to https://w3c.org the error messages not changes (say "http").

  • I am using UBUNTU 18 LTS.

  • sudo apt update is working (!).

1
  • Thanks @Rinzwind, yes, all proxy there! How to remove it? I deleted all changes that I was do in .profile, etc. – Peter Krauss Jul 26 '19 at 15:04
2
env | grep -i proxy

will show if there is anything set in the environment. This will remove the variable if one was set:

unset http_proxy
unset ftp_proxy
unset https_proxy

(You can bypass proxy with curl with the --noproxy option)

.wgetrc might have a proxy=on in the settings file. Also check ~/.profile, /etc/profile ~/.bashrc and /etc/environment for any variables that set a proxy.

3
  • Thanks, unset is working (!), wget alive again! Any problem if I have locate .wgetrc with nothing? – Peter Krauss Jul 26 '19 at 15:09
  • no mine was empty too :) good job getting it working :) – Rinzwind Jul 26 '19 at 16:21
  • hum... Not solved: askubuntu.com/q/1161331/439867 – Peter Krauss Jul 26 '19 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.