I've read some questions similar, but not the exactly the same problem...

I've moved my home directory to a separated partitión (Ubuntu 11.10) following this tutorial.

After confirming all my files and folders, I've installed Fedora 16, but forgot that one of those directories was encrypted by ecryptfs.

So I was surprised when all I found in my home folder was a file, Readme.txt, advising me that my folder was unmounted for security reasons and suggesting that I type on the command line ecryptfs-mount-Private (which didn't work), or click on labeled icon "access your private data" (which didn't work either).

After three days reading all I could find on the internet, I followed Dustin Kirkland's tutorial, but it couldn't find any .ecryptfs.

I'm sure that the data is somewere (the size of the moved dir is identical to the original one). Any help would be greatly appreciated. Thanks a lot.

  • Via Google Translate: Try this or this and see if they help. – Tom Brossman Mar 26 '12 at 11:27
  • Thanks for your quik responses, I'll try and tell you the results. Roberto de Armas – user52161 Mar 26 '12 at 17:05

For me all the above didn't work because my situation was slightly different. I had a separate disk were I mounted my home/ directory on, in my case I called this "Ubuntu Home". For some reason "sudo ecryptfs-recover-private" didn't gave any results. When I changed the name of the disk from "Ubuntu Home" into "home" it finally worked!

Apparently the script ecryptfs-recover-private does not just look for the ./Private dir, but first for the /home/ dir. I hope this information helps some other people out! Now I just have to figure out how to hook up my encrypted disk again to a fresh new installation... (at least I again have access to my files!)

@Dustin Kirkland, thanks for your great work! I hope you can improve ecryptfs-recover-private even further. :)


thank you so much for asking this question here! (Previously, it was a private email thread between Roberto and I).

You said you've tried following my tutorial describing how to recover your encrypted home directory. If you're sure you have all of your data under /home, I'm quite confident that it will work properly for you.

Please ensure that:

  1. You boot from an Ubuntu 11.10 Desktop Live CD. I know you're running Fedora, and it should very well be possible to recover using Fedora's eCryptfs utilities, but I've never done it before.
  2. You mount your existing hard drive. The Ubuntu Desktop Live CD should detect and mount your drives/partitions.
  3. Find your /home partition. Browse that directory structure. Make absolutely sure that you have all of these directories:
    • /home/.ecryptfs/$USER/.ecryptfs
    • /home/.ecryptfs/$USER/.Private
    • /home/$USER/.ecryptfs/
    • /home/$USER/.Private/
  4. Once you've found all of these, just run ecryptfs-recover-private as described in that post. It will create a read-only mount of your cleartext data, which I strongly recommend backing up somewhere, and then restoring it (in cleartext) in your new Fedora installation.

If this doesn't work for you, then you're missing one of the fundamental pieces mentioned above. Please add comments to the bottom of this answer if this doesn't solve it for you.


Full disclosure: I'm one of the authors and maintainers of Ubuntu Encrypted Home Directory feature, and eCryptfs.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.