0

Upon logging in on Lubuntu 19.04 it is using sddm, but when the computer is idle too long and it goes into idle, when I go to log back in it is using xscreensaver(which I can't stand the look of). I installed gdm3 in an attempt to change both over to a single interface, but all it did is replace sddm leaving xscreensaver as my login after idle. How can I replace xscreensaver in Lubuntu?

  • 1
    Why didn't you just disable screensaver (manual.lubuntu.me/3/3.2/3.2.20/…) ; Lubuntu uses it as it's locker (so whilst disabling it will disable all screensaver functions, the locker will remain), so switching to gdm3 I wouldn't have expected to have impact on xscreensaver locking. – guiverc Jul 26 at 0:26
4

Why your solution didn't work

LXQt uses xdg-screensaverlock to handle locking. This tool generally chooses the screensaver based on the desktop environment but xscreensaver takes precedence so that eliminates some other options, including gnome-screensaver¹.

The real solution

Luckily, there are others that take precedence over xscreensaver, including the one that trumps them all: xautolock. Technically that's not a locker, so you'd need something else. Something light like xtrlock would do the trick (and it's super light).

Make sure you autostart xautolock -locker "xtrlock -b" (remove the -b if you don't want the screen blanked) and keep xscreensaver from starting:

  1. Navigate to Menu » Preferences » LXQt Settings » Session Settings » Autostart
  2. Uncheck the check box next to Xscreensaver
  3. Click the Add button
  4. In the Name field add something like "xautolock xtrlock"
  5. In the Command field add xautolock -locker "xtrlock -b"
  6. Click OK
  7. Click Close
  8. Log out and back out again

You can fix xscreensaver, too

Since your primary issue is looks, You might want to look into theming xscreensaver's lock dialog. This is arguably a much wiser solution as xscreensaver is really notable for its commitment to security, i.e. to actually work under any conditions as a locker.


¹ …which is not included with gdm3, so you didn't install another lock mechanism. If you did want this single interface, you'd need to install the screensaver as well. You'd also have to do the above except instead of xautolock you could use gnome-screensaver. I wouldn't recommend this any more than I would recommend trying to use KDE's locker (which is not sddmas it seems) since they are tightly integrated into the desktop environment and kind of useless outside of it.

  • I'm not talking about the screen saver, I have the screensaver disabled so I will just get a blank screen. But when I wake the computer from idle it asks for my password using the xscreensaver interface instead of the seem interface. – Daniel Jul 27 at 2:12
  • Ah misunderstood the problem. Revised the answer entirely. – wxl Jul 27 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.