2

I recently downgraded to 18.04 and I've encountered a problem I've never had with any other Linux version or distros. Every time I unlock my computer, the screen is rotated. The only way to un-rotate it is xrandr -o normal. I don't have any screen rotation options in the upper-right menu or Tweaks. There is an option in Settings and it's always set to landscape by default. No options to disable auto-rotate. I have a Lenovo Yoga 720.

Here is what I have tried:
- disabled location services
- I removed disabled and removed iio-sensor-proxy
- I get this back, /lib/udev/rules.d/80-iio-sensor-proxy.rules as one of the results from apt-file list iio-sensor-proxy but don't have a file in that directory. 80-debian-compat.rules, 80-drivers.rules, 80-ifupdown.rules, 80-libinput-device-groups.rules, 80-mm-candidate.rules, 80-net-setup-link.rules and 80-udisks2.rules
- gsettings set org.gnome.settings-daemon.plugins.orientation active false doesn't do anything.

1 Answer 1

0

Thanks to some very nice Yoopers, we may have a solution:

If the screen on your Lenovo Twist Ultrabook is displaying upside down or on its side, the easiest way to rotate the screen to the desired position is hold down the Ctrl and Alt keys simultaneously while also clicking the up, down, right or left arrow keys to change the orientation of your display (Usually this is CTRL + ALT + Arrow Up).

If the key combinations don't work put the computer in tablet mode by laying the display 'screen side up' on the keyboard and then putting it back into laptop mode and try them again.

3
  • 1
    I have a Lenovo Yoga, not a Twist Ultrabook. CTRL + ALT and up, down, left, right doesn't do anything. CTRL + ALT up and down changes the workstation though. I have tried switching from laptop to tablet and back, does not make a difference. Jul 26, 2019 at 0:52
  • gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true Wayland or X11 session?
    – nobody
    Jul 26, 2019 at 11:11
  • 1
    @nobody entering that doesn't do anything :/ and it happens on both Jul 27, 2019 at 5:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .