0

So this is something strange..

  • As a test, I installed a webserver on my workstation (using easyengine).
  • I installed 1 website on the webserver
  • I removed the website again, and installed in on the server where it belongs

Now I can reach the website from everywhere in the world (www.virtuality.site), but NOT from my workstation..

How is this possible? Somehow the workstation only looks locally but can't find anything (there's no longer a webserver installed!

Any help is greatly appreciated! :)

edit: this is the output or traceroute, as suspected (but no clue what to do about it):

traceroute to virtuality.site (127.0.0.1), 30 hops max, 60 byte packets 1 localhost (127.0.0.1) 0.019 ms 0.003 ms 0.004 ms

4
  • 1
    In your workstation the domain name virtuality.site is still associated with the localhost IP of 127.0.0.1. This is a special IP address to connect to the workstation itself. Some setting was probably changed when you used easyengin on the workstation so that this domain name points to the localhost. Please copy and paste the content of etc/hostname in the question.
    – user68186
    Jul 25, 2019 at 21:49
  • yes indeed.. The question remains: where can such a setting be hiding? Routingtables?
    – Warner
    Jul 25, 2019 at 21:51
  • 1
    I meant etc/hosts.
    – user68186
    Jul 25, 2019 at 21:55
  • Yes! An entry in etc/hosts was the cause of this. Thanks a lot!
    – Warner
    Jul 26, 2019 at 6:41

1 Answer 1

1

In your workstation the domain name virtuality.site is still associated with the localhost IP of 127.0.0.1.

This is a special IP address to connect to the workstation itself. Some setting was probably changed when you used easyengin on the workstation so that this domain name points to the localhost.

Check the contents of the file /etc/hosts. Edit the file with nano:

sudo nano /etc/hosts

If it contains the line:

127.0.0.1   www.virtuality.site     localhost

Then remove the www.virtuality.site from that line and make it look like:

127.0.0.1   localhost

Save the files and exit the text editor and restart the workstation.

See more at What is the use of /etc/hosts?

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.