I have tried to install Lubuntu 18.04 on an Acer Switch 3 (which allows only EFI boot, has no legacy mode). For more than a week I have not managed to make the system start.

Today I have restarted the tablet after a long time, and very suprisingly, Lubuntu has booted immediately. Then, after a lengthy update, I was asked to restart, and now it does not start anymore. Instead I get the message

Default Boot Device Missing or Boot Failed. Insert Revocery Media and Hit any key Then select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media

Since the system is there, I would like to boot it nevertheless. Unluckily, I forgot to create a boot media.

So this is my question: Is there any "generic" way to boot the installed system using a usb device? A tool or something that can analyze the disk and reckognize a bootable OS?

Thanks in advance!


this is the link to the boot-repair output:



boot-repair has actually worked. So the problem as such is solved. But the question, technically speaking, is not answered yet. So what should I do with this question? Wait for an answer, that might be interesting in its own right?


here the result of boot-repair, after the repair action. http://paste.ubuntu.com/p/45Xt76hVG8/

  • Does it still have Windows? It is possible to boot from the Live USB Ubuntu install disk and choose the option "Try without installing..." Then you can look into the installed system files and figure out what's wrong and possibly fix it.
    – user68186
    Jul 25, 2019 at 16:28
  • No Windows. Only this system. Yes, I can do that, but I am simply not an expert for EFI boot. Much less do I have any idea why the system booted once and then no more. This is why I was hoping there exists a tool to help me. Jul 25, 2019 at 16:43
  • there is a tool called boot-repair you can (temporarily) install it on the Live USB and run it from there. It can run diagnostics and suggest solutions. You can post a link to the diagnostic output in your question so that someone can look at it and help you.
    – user68186
    Jul 25, 2019 at 16:47
  • 1
    Is this a 32 bit UEFI on 64 bit system? But Acer typically requires "trust" setting in UEFI to enable booting anything other than Windows. Acer Aspire E15 will not dual boot, many details Trust settings in step 35 askubuntu.com/questions/627416/… If not "trust" setting post link to summary report from Boot-Repair. Some with UEFI use rEFInd to boot. I have used it on flash drive to boot my UEFI install. rodsbooks.com/refind There also is supergrubdisk.org/rescatux I used to use supergrub for BIOS emergency boot.
    – oldfred
    Jul 25, 2019 at 16:57
  • Try going into the bios and select a boot target from the EFI bootloader there. Jul 25, 2019 at 18:03

1 Answer 1


I'm glad to read that your problem is actually solved with the help of boot-repair.

Regarding your original question, I think Super Grub is what you are looking for. I have never used this tool so far, what I always do is to keep the pendrive with the Ubuntu installer in reach, so in the worst case I have a full featured operating system which I can boot, even if all my harddisks refuse to work. We can use it to run file system checks, edit broken system files and so on.

  • Thanks for this answer. I want to point out that I have solved the problem simply by invoking boot-repair default behavior, without any modification or alteration, the details of which can be seen in the updated question. I have not invoked Super Grub, although it is a good answer to the original question. Jul 26, 2019 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.