4

I want to share a folder.

I went to the Documents folder, right clicked, turned on sharing, gave it a name.

Nautilus installed Samba and said it was working.

I navigated to the "Other locations" area and found my computer's name.

I clicked into that and found the share.

Clicked that and it asked for an anonymous connection or a registered connection.

I tried both and both times it failed. I can't connect with any machine on the network though others can see it.

What's happening? I've restarted the computer but still the same. A constant request for password each time I enter and try and connect.

EDIT: Here is the updated info as requested below:

$ net usershare info --long
[NUCDocs]
path=/home/rob/Documents
comment=
usershare_acl=Everyone:F,
guest_ok=n
1

Your share requires a username and password to access.

So let's take the user "rob" as an example. Unlike Windows there are 2 passwords for "rob" in Linux / Samba. The local login password for that user and the samba password for that user.

You assign a samba password to that user with this command:

sudo smbpasswd -a rob

It can be identical to the local login password if you want but "rob" needs to added the samba password database with the above command.

| improve this answer | |
  • Thank you for this. Finally got back to it. It worked and makes perfect sense. It's a shame nautilus doesn't mention this, but there it is. Done. Appreciate your time spent helping – robster Aug 21 '19 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.