0

My laptop has a bcm43142 driver which is proprietary, but when I used Ubuntu and Lubuntu, it was very easy to enable through Additional Drivers. My laptop does not have an LAN cable, so I use USB tethering from my phone. On Ubuntu Server, I installed ubuntu-drivers and tried to install the compatible driver, bcmwl-kernel-source. I am very new to linux and I don't even know if this question is valid. I scoured this site and the web for answers but nothing worked. I have internet access only through my phone. Also, when installing Ubuntu Server, I used my phone as a network.

The following picture contains the output of these commands:

sudo lspci -nnk
uname -a
ip addr 

https://i.stack.imgur.com/uJouX.jpg

output for sudo netplan --debug apply

https://i.stack.imgur.com/gGorM.jpg

  • post the sudo lspci -nnk, uname -a and ip addr. – Pavel Sayekat Jul 24 at 17:40
  • I could not copy output as text as I am on mobile. If the image doesn't suffice you can ask for output again. – buntuifiw Jul 24 at 19:08
  • Welcome to AskUbuntu, hope you find your answer here. My understanding is that the problem you have is that you can't get networking to work through USB tethering without the GUI that the Ubuntu Desktop provides. You could clarify this in the title so that it directly describe your problem, – Bernard Wei Jul 24 at 19:59
  • Actually, USB tethering already does work, I am trying to get wireless working. Anyway, I am reinstalling Ubuntu. I should have specified that I was trying to get wireless working. – buntuifiw Jul 24 at 20:05
  • You have the correct driver installed and you have a wireless interface, namely wlp1s0. I shall propose an answer to get a wireless connection. There is no need, so far, to reinstall. Please also show us: ls /etc/netplan – chili555 Jul 24 at 20:31
0

You have apparently correctly installed the correct driver and you now have a wireless interface, namely wlp1s0. Now let's set up a connection.

Networking in Ubuntu server 18.04 and later is handled by netplan. Let's edit the netplan file to set your details.

You can find useful templates for netplan in /usr/share/doc/netplan/examples.

The file 50-cloud-init.yaml contains a suggestion:

To disable cloud-init's network configuration capabilities, write a file /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following: network: {config: disabled}

Please do so:

sudo -i
echo "network: {config: disabled}"  >  /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg
exit

Please rename your file:

sudo mv /etc/netplan/50-cloud-init.yaml  /etc/netplan/01-netcfg.yaml

Now fill in the file with your relevant details:

sudo nano /etc/netplan/01-netcfg.yaml.yaml

Change the file to read:

network:
  version: 2
  renderer: networkd
  wifis:
    wlp1s0:
      dhcp4: true
      dhcp6: true
      access-points:
        "network_ssid_name":
          password: "**********"

EDIT: Please note that the name of the network, known as SSID and the password are enclosed in quotation marks.

Of course, substitute your exact details here. Spacing and indentation must be perfect. Proofread carefully. Save (Ctrl+o followed by Enter) and exit nano (Ctrl+x).

Follow with:

sudo netplan generate
sudo netplan apply

Upon reboot, you should be connected. Confirm:

ip addr show
ping -c3 www.ubuntu.com

If you get ping returns, you are connected.

  • I have completed these instructions but ping returns no results. I proofread netplan and debugged it, checked if my info was correct, but still no ping results. But there was a difference while booting. For 2 min, something called Wait for Network was being configured. Before this, output is shown with similar proccesses concerning the network. This 2 minute process ends in a failure. This is the furthest I've gotten however, so thanks. – buntuifiw Jul 25 at 1:24
  • Any clues in the message log? dmesg | grep wlp Also, may we see: ip addr show – chili555 Jul 25 at 1:39
  • dmesg | grep wlp : [14.477418] wl 0000:01:00.0 wlp1s0: renamed from wlan0 – buntuifiw Jul 25 at 1:49
  • ip addr show is same as in image plus following : inet6 fe80::da5d:e2ff:fa8a:bca3/64 scope link valid_lft forever preferred_lft forever – buntuifiw Jul 25 at 1:54
  • Please see my edit above in a few moments. Be certain that you enclosed the name of the router, known as SSID in quotation marks " as well as the password. If you did not, after making the change, follow with sudo netplan generate and then: sudo netplan apply. – chili555 Jul 25 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.