0

The device used to work and now I wasn't able to make it work since I have 19.04 version(I upgraded from 18.04). I have another TP-LINK wifi adapter and it works so I don't know what could be happening. I ran a command I found on this same forum and this is the output:

mokutil --sb-state; dkms status
SecureBoot disabled
Platform is in Setup Mode
nvidia, 418.56, 5.0.0-17-generic, x86_64: installed
nvidia, 418.56, 5.0.0-19-generic, x86_64: installed
nvidia, 418.56, 5.0.0-20-generic, x86_64: installed
nvidia, 418.56, 5.0.0-21-generic, x86_64: installed
rtl8812au, 4.3.14, 4.15.0-42-generic, x86_64: built
rtl8812au, 4.3.14, 4.15.0-47-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.15.0-42-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.15.0-43-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.15.0-45-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.15.0-46-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.15.0-47-generic, x86_64: built
rtl8812au, 5.2.20.2, 4.18.0-18-generic, x86_64: built
rtl8812au, 5.3.4, 4.15.0-47-generic, x86_64: built
rtl8812au, 5.3.4, 4.15.0-48-generic, x86_64: built
rtl8812au, 5.3.4, 4.18.0-18-generic, x86_64: built
rtl8812au, 5.3.4, 5.0.0-13-generic, x86_64: built
rtl8812au, 5.3.4, 5.0.0-17-generic, x86_64: installed
rtl8812au, 5.3.4, 5.0.0-19-generic, x86_64: installed
rtl8812au, 5.3.4, 5.0.0-20-generic, x86_64: installed
rtl8812au, 5.3.4, 5.0.0-21-generic, x86_64: installed

Do you know what could be wrong?. Thanks in advance!

2

This error will occur when any minor update occurs in Ubuntu 19.04

You need to run the following command in Ubuntu Terminal, Make sure you need to connect the ethernet cable to enable wifi in your Ubuntu 19.04

  1. $ sudo apt remove bcmwl-kernel-source && sudo apt install git dkms
  2. $ git clone -b extended https://github.com/lwfinger/rtlwifi_new
  3. $ sudo dkms add ./rtlwifi_new
  4. $ sudo dkms install rtlwifi-new/0.6

After that, you need to reboot your system. Now your Wifi Connection will be enabled in your Ubuntu 19.04 PC.

  • 1
    the issue was solved today. Thanks – Juan Jul 25 '19 at 16:38
  • That error happened for me when an automatic minor update in 19.04 & I used the above commands, Now the wifi not detected got fixed! :) – Razor Rassh Jul 25 '19 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.