1

I've had issues with my Synaptics touchpad, and it seems to be with Ubuntu alone (it worked in a previous install of Windows 10 and also works fine with Mint, the latter of which had horrible sensitivity issues). What happens is it will work for a while after booting up and logging in, but then stops working. I do not have a function key on my laptop to turn off the touchpad. If I run

modprobe -r psmouse

and

mobprobe psmouse

it works for another 30 seconds then stops working. If I run those commands again, nothing happens - the touchpad can't click, move, nothing.

I tried first on 19.04, minimal install, installed the xserver-xorg-input-synaptics package, rebooted, and the issue remained. Tried 19.04 full install, installed the same package, nothing. I've tried turning off touchpad mode in 'Mouse and Touchpad' in the Settings, that didn't help. I tried running synclient TouchpadOff=0, nothing.

So then I decided to download 18.04.2 LTS, write it to the USB, and boot from it. I stepped away to do some things and came back, started the install, and the touchpad worked for about 10 seconds before it gave up on me. So instead of installing 18.04.2, I'm writing here to ask what else I can do. It does show up in /proc/bus/input/devices, also. I don't think it is a hardware issue because it worked fine in Windows, not-so-fine but it at least worked in Mint, and it does work for a little while in Ubuntu before giving up.

EDIT: Tried Budgie, Lubuntu, Xubuntu, Kubuntu, and Mint again. All have the same issue of the cursor freezing (including touchpad and pointing stick). I don't think MATE will be much different. I even updated my computer's BIOS (which apparently was 5 years out of date), and the cursor is still incredibly jittery and fails altogether eventually.

0

After updating the BIOS and re-installing Ubuntu 19.04 as a full install, I can confirm the mouse is now working normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.