0

I developed a sample app using Ionic framework and is working fine when I run the serve command. But when I run the command: sudo ionic cordova run android, it doesn't run the app on physical device that I connected using USB cable. I've installed all the required dependencies for Ionic.

Following is the list of dependencies that I've installed:

Gradle: v4.4.1;
Node.js: v8.11.4;
NPM: v5.6.0;
Ionic: v3.9.2;
Cordova: v8.0.0;
Android SDKs from SDK 21 to SDK 29; 

Screenshot of error: Screenshot of error

Android Build tools are also installed.

Can anyone suggest me the solution to run the app on physical device just for testing purpose?

  • Please don't put screenshots or photos of text output. It is better to copy and paste the output directly into your question and format it as code by using the { } icon on top of the edit question window. – user68186 Jul 23 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.