enter image description hereMy Ubuntu 18.04 shutdown forcefully because of a power outage.

Now after restart, I have two new accounts

  • dnetmaster
  • netplan daemon user

In my user profile, the internet does not work.

After reading a few suggestions I activated the network-manager.

But, still my Ethernet card is not being detected. What could be the reason for the above behavior and how can I debug it?

Tried sudo lshw -C network

Here i get *network disabled

  • 2
    What's the ouptut of the command ip addr show? Jul 23, 2019 at 14:40
  • @guillermochamorro I have two interfaces eno1 and lo which I assume is the localhost and the MAC interface. I am missing the eth0 interface Jul 23, 2019 at 14:42
  • 1
    eno1 is your ethernet interface.
    – chili555
    Jul 23, 2019 at 15:07
  • 2
    eno1 is consistent with the default naming scheme for 18.04. The creation of persistent files to rename interfaces is a dead-end attempt to use the old methods. We no longer use wooden wheels on our sleek black BMWs.
    – chili555
    Jul 23, 2019 at 15:23
  • 1
    Does this say that interfaces are managed by NM? cat /etc/NetworkManager/NetworkManager.conf Are there any clues in the log? dmesg | grep eno1 Or here? cat /etc/network/interfaces Or here? cat /etc/netplan/*.yaml Please paste the result of all of those here and give us the link: paste.ubuntu.com
    – chili555
    Jul 23, 2019 at 15:45

1 Answer 1


Thanks to the above suggestions in the comment and some research I got a solution for the above.

What worked:

Manually updating the /etc/network/interfaces file

auto eno1
iface eno1 inet dhcp

Why I believe it works:[Just my understanding]

Because of the force shutdown, netplan has been created as a new user account. Therefore, netplan in the user account is not able to update the


file with the new Ethernet interface mappings.

Will update the answer as I learn more

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .