3

Running Xubuntu (actually Ubuntu Studio) 18.04 LTS on a Toshiba Sattelite p850

Until recently I could control volume by Fn + F9/F10/F11 but the function stopped working. Other keys in combination with the Function key Fn still works as expected, eg Fn + F6/F8 makes Clementine skip to previous or next track in the playlist while Fn + F4 brings up the Display dialog.

I can't think of anything unusual I did, installing updates when they appear in software updater.

I tried searching several forums and found similar problems, but most of them seem to be with Unity which I am not using.

From this post I tried

xfce4-volumed

which gave a lot of error messages like Binding 'XF86AudioLowerVolume' failed!, Binding 'XF86AudioMute' failed! and Binding 'XF86AudioRaiseVolume' failed!

In the Settings Editor I can not find any XF86 properties for Audio, the closest thing is XF86Music which has the value parole.

xev

gives

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  75  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

for volume down and

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

for volume up.

So how do I regain the missing keyboard bindings?

Edit: I also found a related question in an arch forum that says it's possible to add shortcuts through the settings editor, but I don't understand which property or what value to use...

4
  • This is primarily a FYI: Ubuntu Studio was not a LTS release; so it's updates are not SRU'd and released thru normal channels, but extended support (equal to a LTS release) are available via PPA. This may mean if you didn't add the PPA, your Ubuntu Studio components haven't been upgraded with fixes (security & other) If you're not using the Ubuntu Studio PPA for 18.04, I'd suggest adding it - ubuntustudio.org/2019/04/ubuntu-studio-18-04-extended-support
    – guiverc
    Jul 23 '19 at 12:41
  • Yes, I am aware of that and added the PPA some time ago. Maybe I should have said 'semi-LTS' in the post :-)
    – Al F
    Jul 23 '19 at 12:47
  • It appears your volume keys are working (the keystrokes are intercepted by xfce4-volumed) but they're likely pointing at the wrong audio output "track". If you open pavucontrol (which you may have to install, apt install pavucontrol), I suspect your volume buttons are merely tethered to the wrong output device; bring the volume up and down and see which Output Device is modified. Ubuntu bug 883485 or Debian bug 677014 may help you, though they did not help me.
    – Adam Katz
    Nov 7 '19 at 23:26
  • Never mind, I solved it. See my answer below.
    – Adam Katz
    Nov 8 '19 at 0:59
1

I also had this problem and found that I was using the rather old xfce4-volumed rather than its modern replacement, xfce4-pulseaudio-plugin. I removed the old program and installed the new one (sudo apt install xfce4-pulseaudio-plugin), then I added the PulseAudio Panel Plugin to one of my XFCE4 panels: Right-click on a border or separator, go to Panel, then Add New Items. Search for "pulse" and double-click on the PulseAudio Plugin. (See left window in screenshot.)

screen shot

Right-click on the volume icon you just added to your panel and go to Properties (see right window in screenshot). Ensure "Enable Keyboard shortcuts for volume control" is checked. Now click Run Audio Mixer… to launch pavucontrol (you may need to sudo apt install pavucontrol first).

Click on the Output Devices tab and enlarge the window so all of your devices are visible without needing to scroll. Now press your keyboard's volume keys (🔉︎ and 🔊︎) a bunch. You should see one of those sliders start moving left and right. That means everything works, but the system doesn't know which speaker to control (Pulseaudio doesn't have a "Master" channel the way Alsa does).

Now, get to the command line and run pactl list short sinks. You'll see an indexed list of your output devices ("sinks"). Select the one you want, say 3, and then set it to be the default with pacmd set-default-sink 3.

Now tinker with your keyboard's 🔉︎ and 🔊︎ keys some more. You should see the desired slider moving in pavucontrol, and if you're playing some music, you should hear the difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.