2

I have Ubuntu 18.04 installed and would like to use https://gitlab.com/gillesdegottex/dfasma for audio analysis. dfasma links with libQt5Multimedia.so.5 for audio playback. Initially I had the pulseaudio sound system installed and all worked fine. Unfortunately, notably when using skype, the pulseaudio daemon became unresponsive from time to time refusing to play any sound. Which required me to restart the pulseaudio daemon or sometimes even to logout and login again. So I removed the pulseaudio system to use alsa directly. This works fine in skype, but when starting dfasma I get the following warning

pa_context_connect() failed: Connection refused

which is expected as there is no pulseaudio daemon running. Unfortunately, then the libqt5multimedia does not load the alsa plaugin but simply does not play any sounds. I can fix this by means of

 sudo chmod 640 /usr/lib/x86_64-linux-gnu/qt5/plugins/audi/libqtmedia_pulse.so 

which disables loading the pulseaudio plugin in qt5 and then the alsa plugin is loaded and used. The question here is whether I can get the same effect without modifying system files, by means of setting an environment variable or a qt config file somewhere.

1 Answer 1

1

Confirm. I had removed out pulse Qt plugin and have good operating input and output audio within Alsa only. I think it is a bug of Qt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.