1

I have some strange issue here. Update Manager and Synaptic are not able to download packages, but apt has no problem at all.

Update Manager says exactly «Failed to download package files».

I already changed server and cleaned /var/lib/apt/lists/: every time, apt works like a charm, but GUI softwares don't.

I can continue using the command line, but I'd like to understand why this is happening.

Thank you in advance.

EDIT: Synaptic says:

W: Failed to fetch http://pkg.adfinis-sygroup.ch/ubuntu/pool/main/m/mysql-5.7/libmysqlclient20_5.7.27-0ubuntu0.18.04.1_amd64.deb

Could not open file /var/cache/apt/archives/partial/libmysqlclient20_5.7.27-0ubuntu0.18.04.1_amd64.deb - open (2: No such file or directory) [IP: 2001:618:1:129::165 80]

This is repeated for every package to download.

If I try to remove the /var/cache/apt/archives directory I get rm: cannot remove '/var/cache/apt/archives/': Device or resource busy

When I run sudo apt-get update and sudo apt-get upgrade I don't get any errors. Updates get installed correctly. That's what I meant by saying that «apt has no problem at all».

UPDATE: I applied some updates with apt-get forcing IPv4, and everything went smoothly. update-manager still doesn't work.

  • Could you please update your question with the errors you get ? – Soren A Jul 23 at 9:00
  • Thanks for your comment. I update the question. The error message was the one in the question title. I will update again if Synaptic gives more info. – abePdIta Jul 23 at 9:18
  • Please run sudo apt-get update and sudo apt-get upgrade and add any error output to the question. – N0rbert Jul 24 at 9:15
  • Thank you @N0rbert for your comment. I updated the question with more details. As stated before, apt gives no problem. – abePdIta Jul 25 at 7:16
  • @abePdIta Do you remember which protocol apt / apt-get used - IPv4 or IPv6? Do you have any problems with IPv6 resolution in other applications? – N0rbert Jul 25 at 7:46
0

As N0rbert suggested in comments, IPv4 was the thing.

In the question he linked (https://unix.stackexchange.com/a/100887/57134) there are instruction to make apt-get use IPv4 by default. This also affected update-manager and the problem has been solved.

Thanks N0rbert for the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.