Can't seem to find how to sync the built in Calendar that comes with Kubuntu.

Here's what it shows me when I click "Configure Digital Clock":

enter image description here

And this is my System Information:enter image description here

Thank you :)

  • You have to add the calendar in Korganizer..see e.g. ubuntubuzz.com/2017/05/…
    – Bruni
    Jul 23, 2019 at 8:44
  • Hmm. that's odd. Korganizer is a KDE product. Why wasn't it installed by default?
    – AFwcxx
    Jul 23, 2019 at 9:11
  • It's working. Thanks mate. The blog is outdated by the way, the options are different places in Korganizer.
    – AFwcxx
    Jul 23, 2019 at 9:57

3 Answers 3


Try the widget called Event Calendar link.

For installation and setup, refer to its github page

It does the job


Once you've installed and configured KOrganizer, you can use kdepim-addons to let the panel widget show its events.

  1. install KOrganizer as described in totymedli answer
  2. install kdepim-addons: sudo apt install kdepim-addons
  3. Right click on the clock in the panel -> Configure Digital Clock... -> Calendar -> Enable PIM Events Plugin
  4. Still in Digital Clock settings, go to PIM Events Plugin and check all the calendars you want to show in the KDE clock/calendar widget.

Credits: https://zren.github.io/2019/10/19/show-korganizer-events-in-the-panels-calendar


Currently you can't do this. The closest thing is to install a desktop calendar and configure sync in it. For KOrganizer:

  1. Install KOrganizer: sudo apt-get install korganizer the open it
  2. Go to Settings->Configure KOrganizer->General->Calendars tab then Click Add...
  3. Select "Google Calendars and Tasks" then click OK
  4. On the top "Accounts" block then click Add
  5. Login to you Google account then allow access to it
  6. Check "Enable interval refresh" then set how often the syncing should happen
  7. Select the calendars and tasklists you want to import then click OK

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .