4

I have problems with connecting to Nordvpn on my Ubuntu 18.04.02.LTS since 3 days. I am using terminal to connect to servers. When I try to connect to one of server I receive information:

Whoops! We couldn't connect you to 'de'. Please try again. If the problem persists, contact our customer support.

I have done all updates, I tried to reinstall Nordvpn unfortunatelly nothing helps. Problem persists only when I am trying to connect by terminal. I can connect using Network Manager(I am not using that because after 20 minutes my connection drops)

11
  • Try apt purge nordvpn and then reinstall to get rid of some old configuration. You can also try another country.
    – pLumo
    Jul 23, 2019 at 6:34
  • 1
    Did you report this to the "Paid" VPN Service? Jul 23, 2019 at 6:35
  • @pLumo I will try it after work, thank you for tip
    – fidos3k
    Jul 23, 2019 at 7:47
  • 1
    I have solved problem thanks to @pLumo, what I did was: sudo apt purge nordvpn, but I have noticed that not all files has been deleted. In a path /var/lib/nordvpn/data/ I have removed .config.ovpn with sudo rm -R .config.ovpn (I had to change permisions before)
    – fidos3k
    Jul 24, 2019 at 19:57
  • 1
    Great! So please go ahead and write an answer with your steps. You can later accept it, it may help other users.
    – pLumo
    Jul 24, 2019 at 20:00

3 Answers 3

0

Try:

nordvpn logout && sudo chattr -i -a /var/lib/nordvpn/data/.config.ovpn \ 
&& sudo chmod ugo+w /var/lib/nordvpn/data/.config.ovpn && nordvpn login \ 
&& nordvpn connect
0

First I purged nordvpn by running

sudo apt purge nordvpn

but I have noticed that not all files has been deleted. In the path /var/lib/nordvpn/data/ I have removed .config.ovpn with

sudo rm -R .config.ovpn

(I had to change permissions before).


Source: comment by OP

0

This problem comes up periodically with nordvpn updates. It has happened to me four or five times in the last year alone. I'm currently running Ubuntu 18.04.3 LTS but I have experienced these same issues on 18.04.2 LTS.

Here's how I get up and running again.

Note, this solution assumes you running a version of Ubuntu 18.04 and that you have a usable internet connection.

Step 1. Open your terminal.

Step 2. Run nordvpn logout.

Step 3. Run sudo apt purge nordvpn.

Step 4. Run sudo ls -la /var/lib/ and confirm that the nordvpn directory has been removed from /var/lib/. If it's still there we might run into problems later so go ahead and run sudo rm -rf ./nordvpn/ to get rid of it.

Step 5. Run sudo apt install nordvpn. If apt has any issues installing, open up your web browser and navigate to https://nordvpn.com/download/linux/. Go ahead and download the .deb file and install it. Instructions for that process should be available on the download page.

Step 6. Run nordvpn login and enter your NordVPN credentials.

Step 7. Run nordvpn c. After a couple of seconds you should see something like Connecting to United States #XXXX (usXXXX.nordvpn.com). If it succeeds you should see something like You are connected to United States #XXXX (usXXXX.nordvpn.com).

And with that you should be good to go.

If you are having this problem on a different version of Ubuntu then I recommend looking for a different solution before trying this one. Good luck!

1
  • It just occurred to me, it's also worth checking your firewall rules. If you are using OpenVPN as your technology then make sure you ALLOW Out connections on port 443. This is simple to do with Gufw Firewall.
    – Drew Hans
    Jan 20, 2020 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .